Browse Source

mtdev: fix bad printf formats

Easiest to just change the type.

Signed-off-by: Rosen Penev <rosenp@gmail.com>
lilik-openwrt-22.03
Rosen Penev 2 years ago
committed by Daniel Golle
parent
commit
e6a5bbbc8e
2 changed files with 12 additions and 1 deletions
  1. +1
    -1
      libs/mtdev/Makefile
  2. +11
    -0
      libs/mtdev/patches/010-format.patch

+ 1
- 1
libs/mtdev/Makefile View File

@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=mtdev
PKG_VERSION:=1.1.6
PKG_RELEASE:=1
PKG_RELEASE:=2
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
PKG_SOURCE_URL:=http://bitmath.org/code/mtdev/


+ 11
- 0
libs/mtdev/patches/010-format.patch View File

@ -0,0 +1,11 @@
--- a/test/mtdev-test.c
+++ b/test/mtdev-test.c
@@ -38,7 +38,7 @@
#endif
/* year-proof millisecond event time */
-typedef uint64_t mstime_t;
+typedef unsigned long long mstime_t;
static int use_event(const struct input_event *ev)
{

Loading…
Cancel
Save