Browse Source

ocserv: updated to 0.10.4

Signed-off-by: Nikos Mavrogiannopoulos <nmav@gnutls.org>
lilik-openwrt-22.03
Nikos Mavrogiannopoulos 9 years ago
parent
commit
e5f8c378c1
2 changed files with 3 additions and 25 deletions
  1. +3
    -3
      net/ocserv/Makefile
  2. +0
    -22
      net/ocserv/patches/001-correct-session-expiration.patch

+ 3
- 3
net/ocserv/Makefile View File

@ -8,13 +8,13 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=ocserv
PKG_VERSION:=0.10.3
PKG_RELEASE:=2
PKG_VERSION:=0.10.4
PKG_RELEASE:=1
PKG_BUILD_DIR :=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
PKG_SOURCE_URL:=ftp://ftp.infradead.org/pub/ocserv/
PKG_MD5SUM:=36c947a4e37484487844dc1c977ca870
PKG_MD5SUM:=6df31778642320ea7b90f314c4c9a897
PKG_LICENSE:=GPLv2
PKG_LICENSE_FILES:=COPYING


+ 0
- 22
net/ocserv/patches/001-correct-session-expiration.patch View File

@ -1,22 +0,0 @@
diff --git a/src/sec-mod-auth.c b/src/sec-mod-auth.c
index 4ee6f57..2fc02b5 100644
--- a/src/sec-mod-auth.c
+++ b/src/sec-mod-auth.c
@@ -500,7 +500,7 @@ int handle_sec_auth_session_close(int cfd, sec_mod_st *sec, const SecAuthSession
(pack_func) cli_stats_msg__pack);
}
- if (e->status != PS_AUTH_COMPLETED) {
+ if (e->status < PS_AUTH_COMPLETED) {
seclog(sec, LOG_DEBUG, "session close received in unauthenticated client %s "SESSION_STR"!", e->auth_info.username, e->auth_info.psid);
return send_msg(e, cfd, SM_CMD_AUTH_CLI_STATS, &rep,
(pack_size_func) cli_stats_msg__get_packed_size,
@@ -604,7 +604,7 @@ int handle_sec_auth_stats_cmd(sec_mod_st * sec, const CliStatsMsg * req)
e->stats.uptime = req->uptime;
if (req->has_invalidate_cookie && req->invalidate_cookie != 0) {
- seclog(sec, LOG_INFO, "invalidating session user '%s' "SESSION_STR,
+ seclog(sec, LOG_INFO, "invalidating session of user '%s' "SESSION_STR,
e->auth_info.username, e->auth_info.psid);
e->status = PS_AUTH_USER_TERM;
}

Loading…
Cancel
Save