Browse Source

libwebsockets: Fix build without deprecated OpenSSL APIs

Signed-off-by: Rosen Penev <rosenp@gmail.com>
lilik-openwrt-22.03
Rosen Penev 6 years ago
committed by Karl Palsson
parent
commit
e54ecea1b0
3 changed files with 13 additions and 2 deletions
  1. +1
    -1
      libs/libwebsockets/Makefile
  2. +11
    -0
      libs/libwebsockets/patches/010-openssl-deprecated.patch
  3. +1
    -1
      libs/libwebsockets/patches/020-fix-travis.patch

+ 1
- 1
libs/libwebsockets/Makefile View File

@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=libwebsockets
PKG_VERSION:=3.0.1
PKG_RELEASE:=1
PKG_RELEASE:=2
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)


+ 11
- 0
libs/libwebsockets/patches/010-openssl-deprecated.patch View File

@ -0,0 +1,11 @@
--- a/lib/tls/private.h
+++ b/lib/tls/private.h
@@ -64,6 +64,8 @@
#include <openssl/err.h>
#include <openssl/md5.h>
#include <openssl/sha.h>
+ #include <openssl/rsa.h>
+ #include <openssl/bn.h>
#ifdef LWS_HAVE_OPENSSL_ECDH_H
#include <openssl/ecdh.h>
#endif

+ 1
- 1
libs/libwebsockets/patches/020-fix-travis.patch View File

@ -2,7 +2,7 @@ diff --git a/CMakeLists.txt b/CMakeLists.txt
index b260969..ece281d 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -1050,9 +1050,9 @@ if (CMAKE_COMPILER_IS_GNUCC OR CMAKE_COMPILER_IS_GNUCXX OR (CMAKE_C_COMPILER_ID
@@ -1055,9 +1055,9 @@ if (CMAKE_COMPILER_IS_GNUCC OR CMAKE_COMPILER_IS_GNUCXX OR (CMAKE_C_COMPILER_ID
endif()
if (UNIX AND NOT LWS_WITH_ESP32)


Loading…
Cancel
Save