Browse Source

libnet-1.2.x: fix musl compatiblity

The correct includes for musl are protected by an __GLIBC__ check in the
upstream sources.

Since musl does not provide own defines to identify itself, simply invert
the condition to !__UCLIBC__ in order to fix the build on all libc flavors
supported by OpenWrt.

Signed-off-by: Jo-Philipp Wich <jow@openwrt.org>
lilik-openwrt-22.03
Jo-Philipp Wich 9 years ago
parent
commit
e4925c1efd
2 changed files with 12 additions and 1 deletions
  1. +1
    -1
      libs/libnet-1.2.x/Makefile
  2. +11
    -0
      libs/libnet-1.2.x/patches/100-musl-compat.patch

+ 1
- 1
libs/libnet-1.2.x/Makefile View File

@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=libnet
PKG_VERSION:=1.2-rc3
PKG_RELEASE:=1
PKG_RELEASE:=2
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=http://sourceforge.net/projects/libnet-dev/files/


+ 11
- 0
libs/libnet-1.2.x/patches/100-musl-compat.patch View File

@ -0,0 +1,11 @@
--- a/src/libnet_link_linux.c
+++ b/src/libnet_link_linux.c
@@ -30,7 +30,7 @@
#include <sys/time.h>
#include <net/if.h>
-#if (__GLIBC__)
+#if (!__UCLIBC__)
#include <netinet/if_ether.h>
#include <net/if_arp.h>
#else

Loading…
Cancel
Save