Browse Source

git: ship with absolute symlink to git (#10221)

Fixes regression already fixed in oldpackages commit
012eec3f60
but re-introduced in commit 6636e13f2a.

This patch also enables IPv6 support.

Signed-off-by: Ondřej Caletka <ondrej@caletka.cz>
lilik-openwrt-22.03
Ondřej Caletka 9 years ago
parent
commit
e41142a67a
2 changed files with 2 additions and 2 deletions
  1. +1
    -1
      net/git/Makefile
  2. +1
    -1
      net/git/patches/100-convert_builtin.patch

+ 1
- 1
net/git/Makefile View File

@ -64,7 +64,6 @@ MAKE_FLAGS := \
NO_MKSTEMPS="YesPlease" \
NO_GETTEXT="YesPlease" \
NO_UNIX_SOCKETS="YesPlease" \
NO_IPV6="YesPlease" \
NO_ICONV="YesPlease" \
NO_NSEC="YesPlease" \
NO_PERL="YesPlease" \
@ -88,6 +87,7 @@ define Package/git/install
$(RM) $(PKG_INSTALL_DIR)/usr/bin/git-cvsserver
$(CP) $(PKG_INSTALL_DIR)/usr/bin/git-* $(1)/usr/bin
$(INSTALL_DIR) $(1)/usr/lib/git-core
$(LN) /usr/bin/git $(1)/usr/lib/git-core/git
( cd $(PKG_INSTALL_DIR); $(TAR) \
--exclude=usr/lib/git-core/git-http-backend \
--exclude=usr/lib/git-core/git-http-fetch \


+ 1
- 1
net/git/patches/100-convert_builtin.patch View File

@ -49,7 +49,7 @@
git-http-fetch$X: http.o http-walker.o http-fetch.o GIT-LDFLAGS $(GITLIBS)
$(QUIET_LINK)$(CC) $(ALL_CFLAGS) -o $@ $(ALL_LDFLAGS) $(filter %.o,$^) \
$(LIBS) $(CURL_LIBCURL)
@@ -2277,10 +2269,11 @@ endif
@@ -2279,10 +2271,11 @@ endif
bindir=$$(cd '$(DESTDIR_SQ)$(bindir_SQ)' && pwd) && \
execdir=$$(cd '$(DESTDIR_SQ)$(gitexec_instdir_SQ)' && pwd) && \
{ test "$$bindir/" = "$$execdir/" || \


Loading…
Cancel
Save