Browse Source

openvswitch: enforce the use of the python binary from `packages`

Seems it was not failing for me because it was probably
using my host Python, which may have the `six` package
available.

This patch enforces the use of the packaged Python.
That way, it's more consistent that the python-six
package is available.

Signed-off-by: Alexandru Ardelean <ardeleanalex@gmail.com>
lilik-openwrt-22.03
Alexandru Ardelean 7 years ago
parent
commit
e26a34c6b4
2 changed files with 30 additions and 1 deletions
  1. +4
    -1
      net/openvswitch/Makefile
  2. +26
    -0
      net/openvswitch/patches/0003-override-pythonpath-via-make-vars.patch

+ 4
- 1
net/openvswitch/Makefile View File

@ -118,7 +118,10 @@ CONFIGURE_ARGS += --enable-shared
TARGET_CFLAGS += -flto -std=gnu99
CONFIGURE_VARS += KARCH=$(LINUX_KARCH)
MAKE_FLAGS += ARCH="$(LINUX_KARCH)"
MAKE_FLAGS += \
ARCH="$(LINUX_KARCH)" \
PYTHONPATH="$(HOST_PYTHONPATH)" \
PYTHON="$(HOST_PYTHON_BIN)"
define OvsBinUtility
define Package/openvswitch-$(1)


+ 26
- 0
net/openvswitch/patches/0003-override-pythonpath-via-make-vars.patch View File

@ -0,0 +1,26 @@
diff --git a/Makefile.am b/Makefile.am
index a4dd7b8..099a3c1 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -53,7 +53,7 @@ endif
# foo/__init__.py into an (older) version with plain foo.py, since
# foo/__init__.pyc will cause Python to ignore foo.py.
run_python = \
- PYTHONPATH=$(top_srcdir)/python$(psep)$$PYTHONPATH \
+ PYTHONPATH=$(top_srcdir)/python$(psep)$(PYTHONPATH) \
PYTHONDONTWRITEBYTECODE=yes $(PYTHON)
ALL_LOCAL =
diff --git a/Makefile.in b/Makefile.in
index 8df66e2..98b54bf 100644
--- a/Makefile.in
+++ b/Makefile.in
@@ -1654,7 +1654,7 @@ AM_CFLAGS = -Wstrict-prototypes $(WARNING_FLAGS) $(OVS_CFLAGS) \
# foo/__init__.py into an (older) version with plain foo.py, since
# foo/__init__.pyc will cause Python to ignore foo.py.
run_python = \
- PYTHONPATH=$(top_srcdir)/python$(psep)$$PYTHONPATH \
+ PYTHONPATH=$(top_srcdir)/python$(psep)$(PYTHONPATH) \
PYTHONDONTWRITEBYTECODE=yes $(PYTHON)

Loading…
Cancel
Save