Browse Source

openvswitch: upgrade to version 2.3.90

lilik-openwrt-22.03
Emanuele Bovisio 10 years ago
parent
commit
dfd640394c
5 changed files with 8 additions and 85 deletions
  1. +6
    -6
      net/openvswitch/Makefile
  2. +1
    -1
      net/openvswitch/patches/0001-netdev-linux-Use-unsigned-int-for-ifi_flags.patch
  3. +1
    -1
      net/openvswitch/patches/0002-netdev-linux-Let-interface-flag-survive-internal-por.patch
  4. +0
    -36
      net/openvswitch/patches/0003-lib-util.h-Disable-ovs_assert-when-build-with-NDEBUG.patch
  5. +0
    -41
      net/openvswitch/patches/0004-datapath-Use-ccflags-y-instead-of-deprecated-EXTRA_C.patch

+ 6
- 6
net/openvswitch/Makefile View File

@ -12,7 +12,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=openvswitch
PKG_RELEASE:=2
PKG_VERSION:=2.3.1
PKG_VERSION:=2.3.90
PKG_RELEASE=$(PKG_SOURCE_VERSION)
PKG_LICENSE:=Apache-2.0
PKG_LICENSE_FILES:=COPYING
@ -21,7 +21,7 @@ PKG_USE_MIPS16:=0
PKG_SOURCE_PROTO:=git
PKG_SOURCE_URL:=https://github.com/openvswitch/ovs
PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
PKG_SOURCE_VERSION:=0dfed4ba9c8a16a1f316d709b7831a4e139472d4
PKG_SOURCE_VERSION:=58be9c9fd732b5bdd3d4c2e9b8cc2313f570094d
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)-$(PKG_SOURCE_VERSION).tar.gz
include $(INCLUDE_DIR)/package.mk
@ -149,10 +149,10 @@ define Package/openvswitch/install
$(INSTALL_BIN) ./files/etc/init.d/openvswitch.init $(1)/etc/init.d/openvswitch
$(INSTALL_DIR) $(1)/usr/lib/
$(CP) $(PKG_BUILD_DIR)/lib/.libs/libsflow-$(PKG_VERSION).so $(1)/usr/lib/
$(CP) $(PKG_BUILD_DIR)/lib/.libs/libopenvswitch-$(PKG_VERSION).so $(1)/usr/lib/
$(CP) $(PKG_BUILD_DIR)/ofproto/.libs/libofproto-$(PKG_VERSION).so $(1)/usr/lib/
$(CP) $(PKG_BUILD_DIR)/ovsdb/.libs/libovsdb-$(PKG_VERSION).so $(1)/usr/lib/
$(CP) $(PKG_BUILD_DIR)/lib/.libs/libsflow.so* $(1)/usr/lib/
$(CP) $(PKG_BUILD_DIR)/lib/.libs/libopenvswitch.so* $(1)/usr/lib/
$(CP) $(PKG_BUILD_DIR)/ofproto/.libs/libofproto.so* $(1)/usr/lib/
$(CP) $(PKG_BUILD_DIR)/ovsdb/.libs/libovsdb.so* $(1)/usr/lib/
$(INSTALL_DIR) $(1)/usr/bin/
$(INSTALL_BIN) $(PKG_BUILD_DIR)/utilities/.libs/ovs-appctl $(1)/usr/bin/


net/openvswitch/patches/0002-netdev-linux-Use-unsigned-int-for-ifi_flags.patch → net/openvswitch/patches/0001-netdev-linux-Use-unsigned-int-for-ifi_flags.patch View File


net/openvswitch/patches/0001-netdev-linux-Let-interface-flag-survive-internal-por.patch → net/openvswitch/patches/0002-netdev-linux-Let-interface-flag-survive-internal-por.patch View File


+ 0
- 36
net/openvswitch/patches/0003-lib-util.h-Disable-ovs_assert-when-build-with-NDEBUG.patch View File

@ -1,36 +0,0 @@
From 34b51e26555d05c00b2320f943a645added5dae4 Mon Sep 17 00:00:00 2001
From: Helmut Schaa <helmut.schaa@googlemail.com>
Date: Mon, 9 Dec 2013 14:15:11 +0100
Subject: [PATCH 5/6] lib/util.h: Disable ovs_assert when build with NDEBUG
Reduces binary size. Use a static inline function instead of
a macro to not get "unused variable" warning everywhere.
Signed-off-by: Helmut Schaa <helmut.schaa@googlemail.com>
---
lib/util.h | 5 +++++
1 file changed, 5 insertions(+)
diff --git a/lib/util.h b/lib/util.h
index 5c23962..9e5866d 100644
--- a/lib/util.h
+++ b/lib/util.h
@@ -69,10 +69,15 @@
* - Writes the failure message to the log.
*
* - Not affected by NDEBUG. */
+#ifndef NDEBUG
#define ovs_assert(CONDITION) \
if (!OVS_LIKELY(CONDITION)) { \
ovs_assert_failure(SOURCE_LOCATOR, __func__, #CONDITION); \
}
+#else
+static inline void ovs_assert(bool cond OVS_UNUSED) {}
+#endif
+
void ovs_assert_failure(const char *, const char *, const char *) NO_RETURN;
/* Casts 'pointer' to 'type' and issues a compiler warning if the cast changes
--
1.8.1.4

+ 0
- 41
net/openvswitch/patches/0004-datapath-Use-ccflags-y-instead-of-deprecated-EXTRA_C.patch View File

@ -1,41 +0,0 @@
From 36fd4f214f9ba74aaf0e5fb3e4ba271b946a1550 Mon Sep 17 00:00:00 2001
From: Thomas Graf <tgraf@noironetworks.com>
Date: Wed, 26 Nov 2014 15:52:31 +0100
Subject: [PATCH] datapath: Use ccflags-y instead of deprecated EXTRA_CFLAGS
This allows users to pass in additional compiler flags through the
environment variable EXTRA_CFLAGS, e.g.
make EXTRA_CFLAGS=-Wno-error=foo V=1
Reported-by: Alexandru Ardelean <ardeleanalex@gmail.com>
Signed-off-by: Thomas Graf <tgraf@noironetworks.com>
Acked-by: Pravin B Shelar <pshelar@nicira.com>
---
datapath/linux/Kbuild.in | 10 +++++-----
1 file changed, 5 insertions(+), 5 deletions(-)
diff --git a/datapath/linux/Kbuild.in b/datapath/linux/Kbuild.in
index 6f6f65f..cb98c11 100644
--- a/datapath/linux/Kbuild.in
+++ b/datapath/linux/Kbuild.in
@@ -7,11 +7,11 @@ export VERSION = @VERSION@
include $(srcdir)/../Modules.mk
include $(srcdir)/Modules.mk
-EXTRA_CFLAGS := -DVERSION=\"$(VERSION)\"
-EXTRA_CFLAGS += -I$(srcdir)/..
-EXTRA_CFLAGS += -I$(builddir)/..
-EXTRA_CFLAGS += -g
-EXTRA_CFLAGS += -include $(builddir)/kcompat.h
+ccflags-y := -DVERSION=\"$(VERSION)\"
+ccflags-y += -I$(srcdir)/..
+ccflags-y += -I$(builddir)/..
+ccflags-y += -g
+ccflags-y += -include $(builddir)/kcompat.h
# These include directories have to go before -I$(KSRC)/include.
# NOSTDINC_FLAGS just happens to be a variable that goes in the
--
2.1.2

Loading…
Cancel
Save