Browse Source

python-cryptography: update to 1.5

The cmac patch was upstreamed (pyca/cryptography#3062).

Signed-off-by: Jeffery To <jeffery.to@gmail.com>
lilik-openwrt-22.03
Jeffery To 8 years ago
parent
commit
de9aa513a5
2 changed files with 3 additions and 25 deletions
  1. +3
    -3
      lang/python-cryptography/Makefile
  2. +0
    -22
      lang/python-cryptography/patches/001-cmac-check.patch

+ 3
- 3
lang/python-cryptography/Makefile View File

@ -8,12 +8,12 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=cryptography
PKG_VERSION:=1.4
PKG_VERSION:=1.5
PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=https://pypi.python.org/packages/a9/5b/a383b3a778609fe8177bd51307b5ebeee369b353550675353f46cb99c6f0
PKG_MD5SUM:=a9763e3831cc7cdb402c028fac1ceb39
PKG_SOURCE_URL:=https://pypi.python.org/packages/6e/96/b8dab146e8be98061dae07e127f80cffa3061ab0e8da0d3d42f3308c6e91
PKG_MD5SUM:=d85a91af3e943c68fa5ff82a3ccdd5df
PKG_BUILD_DEPENDS:=python-cffi/host


+ 0
- 22
lang/python-cryptography/patches/001-cmac-check.patch View File

@ -1,22 +0,0 @@
diff --git a/src/_cffi_src/openssl/cmac.py b/src/_cffi_src/openssl/cmac.py
index f4a3686..bf52144 100644
--- a/src/_cffi_src/openssl/cmac.py
+++ b/src/_cffi_src/openssl/cmac.py
@@ -5,7 +5,7 @@
from __future__ import absolute_import, division, print_function
INCLUDES = """
-#if OPENSSL_VERSION_NUMBER >= 0x10001000L
+#if !defined(OPENSSL_NO_CMAC) && OPENSSL_VERSION_NUMBER >= 0x10001000L
#include <openssl/cmac.h>
#endif
"""
@@ -28,7 +28,7 @@ void CMAC_CTX_free(CMAC_CTX *);
"""
CUSTOMIZATIONS = """
-#if OPENSSL_VERSION_NUMBER < 0x10001000L
+#if defined(OPENSSL_NO_CMAC) || OPENSSL_VERSION_NUMBER < 0x10001000L
static const long Cryptography_HAS_CMAC = 0;
typedef void CMAC_CTX;

Loading…
Cancel
Save