Browse Source

nail: unbreak compilation

disabling SSLv2 and SSLv3 caused nail to break, fixed this
some of our snapshot builders don't have CVS, switch to Debian as source

Signed-off-by: Steven Barth <steven@midlink.org>
lilik-openwrt-22.03
Steven Barth 10 years ago
parent
commit
de0ab1305e
2 changed files with 21 additions and 6 deletions
  1. +5
    -6
      mail/nail/Makefile
  2. +16
    -0
      mail/nail/patches/100-handle-openssl-without-sslv2.patch

+ 5
- 6
mail/nail/Makefile View File

@ -8,15 +8,14 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=nail
PKG_VERSION:=
PKG_VERSION:=12.5
PKG_RELEASE:=1
PKG_LICENSE:=BSD-2-Clause
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=:pserver:anonymous@nail.cvs.sourceforge.net:/cvsroot/nail
PKG_SOURCE_SUBDIR:=$(PKG_NAME)
PKG_SOURCE_VERSION:=-D"2014-11-24 00:00"
PKG_SOURCE_PROTO:=cvs
PKG_SOURCE:=heirloom-mailx_$(PKG_VERSION).orig.tar.gz
PKG_SOURCE_URL:=http://ftp.de.debian.org/debian/pool/main/h/heirloom-mailx/
PKG_MD5SUM:=29a6033ef1412824d02eb9d9213cb1f2
PKG_BUILD_DIR:=$(BUILD_DIR)/heirloom-mailx-$(PKG_VERSION)
PKG_INSTALL:=0


+ 16
- 0
mail/nail/patches/100-handle-openssl-without-sslv2.patch View File

@ -0,0 +1,16 @@
--- a/openssl.c
+++ b/openssl.c
@@ -216,9 +216,12 @@ ssl_select_method(const char *uhp)
cp = ssl_method_string(uhp);
if (cp != NULL) {
+#ifndef OPENSSL_NO_SSL2
if (equal(cp, "ssl2"))
method = SSLv2_client_method();
- else if (equal(cp, "ssl3"))
+ else
+#endif
+ if (equal(cp, "ssl3"))
method = SSLv3_client_method();
else if (equal(cp, "tls1"))
method = TLSv1_client_method();

Loading…
Cancel
Save