Browse Source

Merge pull request #13116 from neheb/kl

klish: fix compilation with uClibc-ng
lilik-openwrt-22.03
Rosen Penev 4 years ago
committed by GitHub
parent
commit
dd714efcf8
No known key found for this signature in database GPG Key ID: 4AEE18F83AFDEB23
2 changed files with 11 additions and 10 deletions
  1. +1
    -3
      utils/klish/Makefile
  2. +10
    -7
      utils/klish/patches/010-shell_execute_fix.patch

+ 1
- 3
utils/klish/Makefile View File

@ -10,7 +10,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=klish
PKG_VERSION:=2.2.0
PKG_RELEASE:=1
PKG_RELEASE:=2
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
PKG_SOURCE_URL:=http://libcode.org/attachments/download/77/
@ -54,8 +54,6 @@ endef
CONFIGURE_ARGS += --with-libxml2
TARGET_CFLAGS += -D_XOPEN_SOURCE=500
define Package/klish/install
$(INSTALL_DIR) $(1)/usr/bin
$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/clish $(1)/usr/bin/


+ 10
- 7
utils/klish/patches/010-shell_execute_fix.patch View File

@ -1,16 +1,19 @@
--- a/clish/shell/shell_execute.c
+++ b/clish/shell/shell_execute.c
@@ -19,13 +19,6 @@
@@ -19,12 +19,14 @@
#include <signal.h>
#include <fcntl.h>
-/* Empty signal handler to ignore signal but don't use SIG_IGN. */
+#if defined(__UCLIBC__) && !defined(__UCLIBC_HAS_OBSOLETE_BSD_SIGNAL__)
/* Empty signal handler to ignore signal but don't use SIG_IGN. */
-static void sigignore(int signo)
-{
- signo = signo; /* Happy compiler */
+static int sigignore(int signo)
{
signo = signo; /* Happy compiler */
- return;
-}
-
+ return 0;
}
+#endif
/*-------------------------------------------------------- */
static int clish_shell_lock(const char *lock_path)
{

Loading…
Cancel
Save