|
|
@ -1,10 +1,8 @@ |
|
|
|
--- a/build/ac-macros/macosx.m4 2016-02-09 01:24:13.181409245 -0500
|
|
|
|
+++ b/build/ac-macros/macosx.m4 2016-02-09 01:25:15.873408288 -0500
|
|
|
|
@@ -17,94 +17,4 @@ dnl specific language governing permis
|
|
|
|
dnl under the License. |
|
|
|
dnl =================================================================== |
|
|
|
--- a/build/ac-macros/macosx.m4
|
|
|
|
+++ b/build/ac-macros/macosx.m4
|
|
|
|
@@ -19,80 +19,3 @@ dnl ====================================
|
|
|
|
dnl |
|
|
|
-dnl Mac OS X specific checks
|
|
|
|
dnl Mac OS X specific checks |
|
|
|
|
|
|
|
-dnl SVN_LIB_MACHO_ITERATE
|
|
|
|
-dnl Check for _dyld_image_name and _dyld_image_header availability
|
|
|
@ -42,19 +40,8 @@ |
|
|
|
- #error ProperyList API unavailable.
|
|
|
|
- #endif
|
|
|
|
- ]],[[]])],[
|
|
|
|
- dnl ### Hack. We should only need to pass the -framework options when
|
|
|
|
- dnl linking libsvn_subr, since it is the only library that uses Keychain.
|
|
|
|
- dnl
|
|
|
|
- dnl Unfortunately, libtool 1.5.x doesn't track transitive dependencies for
|
|
|
|
- dnl OS X frameworks like it does for normal libraries, so we need to
|
|
|
|
- dnl explicitly pass the option to all the users of libsvn_subr to allow
|
|
|
|
- dnl static builds to link successfully.
|
|
|
|
- dnl
|
|
|
|
- dnl This does mean that all executables we link will be linked directly
|
|
|
|
- dnl to these frameworks - even when building shared libraries - but that
|
|
|
|
- dnl shouldn't cause any problems.
|
|
|
|
-
|
|
|
|
- LIBS="$LIBS -framework CoreFoundation"
|
|
|
|
- SVN_MACOS_PLIST_LIBS="-framework CoreFoundation"
|
|
|
|
- AC_SUBST(SVN_MACOS_PLIST_LIBS)
|
|
|
|
- AC_DEFINE([SVN_HAVE_MACOS_PLIST], [1],
|
|
|
|
- [Is Mac OS property list API available?])
|
|
|
|
- AC_MSG_RESULT([yes])
|
|
|
@ -84,9 +71,8 @@ |
|
|
|
- #error KeyChain API unavailable.
|
|
|
|
- #endif
|
|
|
|
- ]],[[]])],[
|
|
|
|
- dnl ### Hack, see SVN_LIB_MACOS_PLIST
|
|
|
|
- LIBS="$LIBS -framework Security"
|
|
|
|
- LIBS="$LIBS -framework CoreServices"
|
|
|
|
- SVN_MACOS_KEYCHAIN_LIBS="-framework Security -framework CoreServices"
|
|
|
|
- AC_SUBST(SVN_MACOS_KEYCHAIN_LIBS)
|
|
|
|
- AC_DEFINE([SVN_HAVE_KEYCHAIN_SERVICES], [1], [Is Mac OS KeyChain support enabled?])
|
|
|
|
- AC_MSG_RESULT([yes])
|
|
|
|
- ],[
|
|
|
@ -95,3 +81,16 @@ |
|
|
|
- ])
|
|
|
|
- fi
|
|
|
|
-])
|
|
|
|
--- a/Makefile.in
|
|
|
|
+++ b/Makefile.in
|
|
|
|
@@ -56,8 +56,8 @@ SVN_XML_LIBS = @SVN_XML_LIBS@
|
|
|
|
SVN_ZLIB_LIBS = @SVN_ZLIB_LIBS@ |
|
|
|
SVN_LZ4_LIBS = @SVN_LZ4_LIBS@ |
|
|
|
SVN_UTF8PROC_LIBS = @SVN_UTF8PROC_LIBS@ |
|
|
|
-SVN_MACOS_PLIST_LIBS = @SVN_MACOS_PLIST_LIBS@
|
|
|
|
-SVN_MACOS_KEYCHAIN_LIBS = @SVN_MACOS_KEYCHAIN_LIBS@
|
|
|
|
+SVN_MACOS_PLIST_LIBS =
|
|
|
|
+SVN_MACOS_KEYCHAIN_LIBS =
|
|
|
|
|
|
|
|
LIBS = @LIBS@ |
|
|
|
|