Browse Source

shine: Update to 3.1.1

Signed-off-by: Rosen Penev <rosenp@gmail.com>
lilik-openwrt-22.03
Rosen Penev 6 years ago
parent
commit
dd14b2cb25
2 changed files with 3 additions and 67 deletions
  1. +3
    -3
      sound/shine/Makefile
  2. +0
    -64
      sound/shine/patches/002-fix-name-collision-with-ffmpeg.patch

+ 3
- 3
sound/shine/Makefile View File

@ -8,12 +8,12 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=shine
PKG_VERSION:=3.1.0
PKG_RELEASE:=2
PKG_VERSION:=3.1.1
PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=https://github.com/toots/shine/releases/download/$(PKG_VERSION)/
PKG_HASH:=6c5310bda766b116ed2415d639a27e5e11040e068b4b2db6bd733333e620cb4f
PKG_HASH:=58e61e70128cf73f88635db495bfc17f0dde3ce9c9ac070d505a0cd75b93d384
PKG_LICENSE:=GPL-2.0
PKG_LICENSE_FILES:=COPYING


+ 0
- 64
sound/shine/patches/002-fix-name-collision-with-ffmpeg.patch View File

@ -1,64 +0,0 @@
From 3695118267be9b7a9412c86c7c5424ab47efe7ec Mon Sep 17 00:00:00 2001
From: Romain Beauxis <toots@rastageeks.org>
Date: Thu, 7 Apr 2016 13:20:46 -0500
Subject: [PATCH] Rename slen{1,2}_table to avoid name collision with ffmpeg.
---
src/lib/l3bitstream.c | 4 ++--
src/lib/l3loop.c | 4 ++--
src/lib/tables.c | 4 ++--
src/lib/tables.h | 4 ++--
4 files changed, 8 insertions(+), 8 deletions(-)
--- a/src/lib/l3bitstream.c
+++ b/src/lib/l3bitstream.c
@@ -127,8 +127,8 @@ static void encodeMainData(shine_global_
{
BF_PartHolder **pph = &config->l3stream.scaleFactorsPH[gr][ch];
gr_info *gi = &(si.gr[gr].ch[ch].tt);
- unsigned slen1 = slen1_tab[ gi->scalefac_compress ];
- unsigned slen2 = slen2_tab[ gi->scalefac_compress ];
+ unsigned slen1 = shine_slen1_tab[ gi->scalefac_compress ];
+ unsigned slen2 = shine_slen2_tab[ gi->scalefac_compress ];
int *ix = &config->l3_enc[ch][gr][0];
if ( (gr == 0) || (si.scfsi[ch][0] == 0) )
--- a/src/lib/l3loop.c
+++ b/src/lib/l3loop.c
@@ -287,8 +287,8 @@ int part2_length(int gr, int ch, shine_g
bits = 0;
{
- slen1 = slen1_tab[ gi->scalefac_compress ];
- slen2 = slen2_tab[ gi->scalefac_compress ];
+ slen1 = shine_slen1_tab[ gi->scalefac_compress ];
+ slen2 = shine_slen2_tab[ gi->scalefac_compress ];
if ( !gr || !(config->side_info.scfsi[ch][0]) )
bits += (6 * slen1);
--- a/src/lib/tables.c
+++ b/src/lib/tables.c
@@ -7,8 +7,8 @@
#include "tables.h"
-const int slen1_tab[16] = { 0, 0, 0, 0, 3, 1, 1, 1, 2, 2, 2, 3, 3, 3, 4, 4 };
-const int slen2_tab[16] = { 0, 1, 2, 3, 0, 1, 2, 3, 1, 2, 3, 1, 2, 3, 2, 3 };
+const int shine_slen1_tab[16] = { 0, 0, 0, 0, 3, 1, 1, 1, 2, 2, 2, 3, 3, 3, 4, 4 };
+const int shine_slen2_tab[16] = { 0, 1, 2, 3, 0, 1, 2, 3, 1, 2, 3, 1, 2, 3, 2, 3 };
/* Valid samplerates and bitrates. */
const int samplerates[9] = {
--- a/src/lib/tables.h
+++ b/src/lib/tables.h
@@ -3,8 +3,8 @@
#include "types.h"
-extern const int slen1_tab[16];
-extern const int slen2_tab[16];
+extern const int shine_slen1_tab[16];
+extern const int shine_slen2_tab[16];
extern const int samplerates[9];
extern const int bitrates[16][4];

Loading…
Cancel
Save