Browse Source

Merge pull request #6659 from cshoredaniel/pr-update-gitolite3

Updates for gitolite package
lilik-openwrt-22.03
Hannu Nyman 6 years ago
committed by GitHub
parent
commit
dbb8bbc919
No known key found for this signature in database GPG Key ID: 4AEE18F83AFDEB23
2 changed files with 6 additions and 30 deletions
  1. +6
    -3
      net/gitolite/Makefile
  2. +0
    -27
      net/gitolite/patches/100-fix-missing-hooks-dir.patch

+ 6
- 3
net/gitolite/Makefile View File

@ -8,14 +8,15 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=gitolite
PKG_VERSION:=3.6.6
PKG_VERSION:=3.6.8
PKG_RELEASE:=1
PKG_SOURCE_PROTO:=git
PKG_SOURCE:=$(PKG_NAME)-v$(PKG_VERSION).tar.xz
PKG_MIRROR_HASH:=b2d96c36682391f45c63b21a91fbe77a969a7b362417c851dd0091a06fcc74d9
PKG_MIRROR_HASH:=652d3b3f8ed93b8ef56153337465cc7260974e5cd2653e949da1bb97a8421ea0
PKG_SOURCE_URL:=https://github.com/sitaramc/gitolite.git
PKG_SOURCE_VERSION:=908f8c6f3b8ef5b95829be7155be2557e71f4579
PKG_SOURCE_VERSION:=e126e97a4d5575821f89ae80dac402b017db94aa
PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_SOURCE_SUBDIR)
@ -36,11 +37,13 @@ define Package/gitolite/description
Gitolite is a system for managing access to git repositories. Note you will need to make
sure dropbear does not interfere with OpenSSH as gitolite depends on feature not in
dropbear (to my knowledge).
See https://openwrt.org/docs/guide-user/services/gitolite for a guide on installation.
endef
define Package/gitolite/postinst
sed -i -e 's,/var/run/git,/srv/git,' $${IPKG_INSTROOT}/etc/passwd
sed -i -e 's,git:\(.*\):/bin/false,git:\1:/bin/ash,' $${IPKG_INSTROOT}/etc/passwd
sed -i -e 's,git:x:0:\(.*\)$$,git:x:99999:\1,' $${IPKG_INSTROOT}/etc/shadow
endef
define Build/Configure


+ 0
- 27
net/gitolite/patches/100-fix-missing-hooks-dir.patch View File

@ -1,27 +0,0 @@
From d0409ae1164030913801d37ce5425ed93529c69d Mon Sep 17 00:00:00 2001
From: Daniel Dickinson <gitolite@daniel.thecshore.com>
Date: Fri, 1 Jul 2016 00:37:23 -0400
Subject: [PATCH] Conf::Store: Fix missing hooks dir for symlink
At least when doing 'gitolite setup -pk user.pub', the
symlinking of hooks fails because the hooks directory
does not exist. Make sure we create it if it's missing.
---
src/lib/Gitolite/Conf/Store.pm | 1 +
1 file changed, 1 insertion(+)
diff --git a/src/lib/Gitolite/Conf/Store.pm b/src/lib/Gitolite/Conf/Store.pm
index 5568b3f..aac90d4 100644
--- a/src/lib/Gitolite/Conf/Store.pm
+++ b/src/lib/Gitolite/Conf/Store.pm
@@ -363,6 +363,7 @@ sub store_common {
chmod 0755, "$rc{GL_ADMIN_BASE}/hooks/gitolite-admin/post-update";
$hook_reset++;
}
+ _mkdir("$repo.git/hooks");
# propagate user-defined (custom) hooks to all repos
ln_sf( "$rc{LOCAL_CODE}/hooks/common", "*", "$repo.git/hooks" ) if $rc{LOCAL_CODE};
--
2.7.4

Loading…
Cancel
Save