Browse Source

gerbera: fix compilation with libcxx 10

Missing header for pid_t.

Signed-off-by: Rosen Penev <rosenp@gmail.com>
lilik-openwrt-22.03
Rosen Penev 4 years ago
parent
commit
db69c14a61
No known key found for this signature in database GPG Key ID: 36D31CFA845F0E3B
2 changed files with 23 additions and 1 deletions
  1. +1
    -1
      multimedia/gerbera/Makefile
  2. +22
    -0
      multimedia/gerbera/patches/020-pid.patch

+ 1
- 1
multimedia/gerbera/Makefile View File

@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=gerbera
PKG_VERSION:=1.5.0
PKG_RELEASE:=6
PKG_RELEASE:=7
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=https://codeload.github.com/gerbera/gerbera/tar.gz/v$(PKG_VERSION)?


+ 22
- 0
multimedia/gerbera/patches/020-pid.patch View File

@ -0,0 +1,22 @@
--- a/src/util/process.h
+++ b/src/util/process.h
@@ -35,6 +35,8 @@
#include <memory>
#include <string>
+#include <unistd.h>
+
// forward declaration
class Config;
--- a/src/util/process_executor.h
+++ b/src/util/process_executor.h
@@ -35,6 +35,8 @@
#include <string>
#include <vector>
+#include <unistd.h>
+
#include "executor.h"
class ProcessExecutor : public Executor {

Loading…
Cancel
Save