Browse Source
Merge pull request #11706 from neheb/fork
forked-daapd: fix compilation with newer musl
lilik-openwrt-22.03
Rosen Penev
5 years ago
committed by
GitHub
No known key found for this signature in database
GPG Key ID: 4AEE18F83AFDEB23
2 changed files with
11 additions and
1 deletions
-
sound/forked-daapd/Makefile
-
sound/forked-daapd/patches/010-errno.patch
|
@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk |
|
|
|
|
|
|
|
|
PKG_NAME:=forked-daapd |
|
|
PKG_NAME:=forked-daapd |
|
|
PKG_VERSION:=27.1 |
|
|
PKG_VERSION:=27.1 |
|
|
PKG_RELEASE:=1 |
|
|
|
|
|
|
|
|
PKG_RELEASE:=2 |
|
|
|
|
|
|
|
|
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz |
|
|
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz |
|
|
PKG_SOURCE_URL:=https://github.com/ejurgensen/$(PKG_NAME)/releases/download/$(PKG_VERSION)/ |
|
|
PKG_SOURCE_URL:=https://github.com/ejurgensen/$(PKG_NAME)/releases/download/$(PKG_VERSION)/ |
|
|
|
@ -0,0 +1,10 @@ |
|
|
|
|
|
--- a/src/websocket.c
|
|
|
|
|
|
+++ b/src/websocket.c
|
|
|
|
|
|
@@ -25,6 +25,7 @@
|
|
|
|
|
|
#ifdef HAVE_PTHREAD_NP_H |
|
|
|
|
|
# include <pthread_np.h> |
|
|
|
|
|
#endif |
|
|
|
|
|
+#include <errno.h>
|
|
|
|
|
|
#include <stdbool.h> |
|
|
|
|
|
#include <stdio.h> |
|
|
|
|
|
#include <string.h> |