Browse Source

cmdpad: fix bad scanf format

Signed-off-by: Rosen Penev <rosenp@gmail.com>
lilik-openwrt-22.03
Rosen Penev 2 years ago
parent
commit
d5d8a39b53
2 changed files with 12 additions and 1 deletions
  1. +1
    -1
      utils/cmdpad/Makefile
  2. +11
    -0
      utils/cmdpad/patches/160-format.patch

+ 1
- 1
utils/cmdpad/Makefile View File

@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=cmdpad
PKG_VERSION:=0.0.3
PKG_RELEASE:=5
PKG_RELEASE:=6
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tgz
PKG_SOURCE_URL:=@SF/cmdpad


+ 11
- 0
utils/cmdpad/patches/160-format.patch View File

@ -0,0 +1,11 @@
--- a/src/parse.c
+++ b/src/parse.c
@@ -257,7 +257,7 @@ int ParseCommand( char * pchCommandLine)
pchValue = strtok( pchValue, ",") ;
d2printf( "Value is '%s'\n", pchValue) ;
- if( (pchValue == NULL ) || ( sscanf( pchValue, "%d", &code) != 1) )
+ if( (pchValue == NULL ) || ( sscanf( pchValue, "%hu", &code) != 1) )
return -1 ;
pchValue = strtok( NULL, ",") ;

Loading…
Cancel
Save