Browse Source

sslh: Update to v1.19b

Refresh patches
Update upstream URLs

Signed-off-by: Jonathan McCrohan <jmccrohan@gmail.com>
lilik-openwrt-22.03
Jonathan McCrohan 6 years ago
parent
commit
d305f1144d
3 changed files with 14 additions and 16 deletions
  1. +5
    -5
      net/sslh/Makefile
  2. +5
    -5
      net/sslh/patches/001-no_sslh_select.patch
  3. +4
    -6
      net/sslh/patches/002-configfile-fix.patch

+ 5
- 5
net/sslh/Makefile View File

@ -1,5 +1,5 @@
#
# Copyright (C) 2009-2017 OpenWrt.org
# Copyright (C) 2009-2018 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
@ -8,12 +8,12 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=sslh
PKG_VERSION:=v1.18
PKG_RELEASE:=2
PKG_VERSION:=v1.19b
PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=http://rutschle.net/tech/sslh/
PKG_HASH:=1601a5b377dcafc6b47d2fbb8d4d25cceb83053a4adcc5874d501a2d5a7745ad
PKG_HASH:=10dfc4deffbca94c3ef7535d3f71b213abc78d53ed1e900873d3ca1cc943659c
PKG_LICENSE:=GPL-2.0+
PKG_LICENSE_FILES:=COPYING
@ -25,7 +25,7 @@ define Package/sslh
SUBMENU:=Routing and Redirection
TITLE:=SSL/SSH multiplexer
DEPENDS:=+libconfig +USE_UCLIBC:libpcre +USE_MUSL:libpcre
URL:=http://rutschle.net/tech/sslh.shtml
URL:=https://rutschle.net/tech/sslh/README.html
PKG_MAINTAINER:=Jonathan McCrohan <jmccrohan@gmail.com>
endef


+ 5
- 5
net/sslh/patches/001-no_sslh_select.patch View File

@ -1,15 +1,15 @@
diff --git a/Makefile b/Makefile
index b1cf9ce..28f90c3 100644
--- a/Makefile
+++ b/Makefile
@@ -65,16 +65,12 @@ all: sslh $(MAN) echosrv
@@ -68,7 +68,7 @@ all: sslh $(MAN) echosrv $(CONDITIONAL_T
version.h:
./genver.sh >version.h
-sslh: sslh-fork sslh-select
+sslh: sslh-fork
sslh-fork: version.h $(OBJS) sslh-fork.o Makefile common.h
$(OBJS): version.h
@@ -76,10 +76,6 @@ sslh-fork: version.h $(OBJS) sslh-fork.o
$(CC) $(CFLAGS) $(LDFLAGS) -o sslh-fork sslh-fork.o $(OBJS) $(LIBS)
#strip sslh-fork
@ -20,7 +20,7 @@ index b1cf9ce..28f90c3 100644
systemd-sslh-generator: systemd-sslh-generator.o
$(CC) $(CFLAGS) $(LDFLAGS) -o systemd-sslh-generator systemd-sslh-generator.o -lconfig
@@ -110,7 +106,7 @@ distclean: clean
@@ -115,7 +111,7 @@ distclean: clean
rm -f tags cscope.*
clean:


+ 4
- 6
net/sslh/patches/002-configfile-fix.patch View File

@ -1,5 +1,3 @@
diff --git a/basic.cfg b/basic.cfg
index 54a799c..d938767 100644
--- a/basic.cfg
+++ b/basic.cfg
@@ -1,3 +1,7 @@
@ -10,7 +8,7 @@ index 54a799c..d938767 100644
# This is a basic configuration file that should provide
# sensible values for "standard" setup.
@@ -14,15 +18,16 @@ pidfile: "/var/run/sslh.pid";
@@ -15,15 +19,16 @@ chroot: "/var/empty";
# Change hostname with your external address name.
listen:
(
@ -21,12 +19,12 @@ index 54a799c..d938767 100644
protocols:
(
{ name: "ssh"; service: "ssh"; host: "localhost"; port: "22"; },
{ name: "ssh"; service: "ssh"; host: "localhost"; port: "22"; fork: true; },
{ name: "openvpn"; host: "localhost"; port: "1194"; },
- { name: "xmpp"; host: "localhost"; port: "5222"; },
- { name: "http"; host: "localhost"; port: "80"; },
+# { name: "xmpp"; host: "localhost"; port: "5222"; },
+# { name: "http"; host: "localhost"; port: "80"; },
+# { name: "xmpp"; host: "localhost"; port: "5222"; },
+# { name: "http"; host: "localhost"; port: "80"; },
{ name: "ssl"; host: "localhost"; port: "443"; log_level: 0; },
{ name: "anyprot"; host: "localhost"; port: "443"; }
);

Loading…
Cancel
Save