Browse Source

python3: Updated to version 3.8.1

Removed upstream patch: 002-fix-blake2-detection.patch

Signed-off-by: Josef Schlehofer <pepe.schlehofer@gmail.com>
lilik-openwrt-22.03
Josef Schlehofer 4 years ago
parent
commit
d2c997f39e
No known key found for this signature in database GPG Key ID: B950216FE4329F4C
3 changed files with 3 additions and 14 deletions
  1. +1
    -1
      lang/python/python3-version.mk
  2. +2
    -2
      lang/python/python3/Makefile
  3. +0
    -11
      lang/python/python3/patches/002-fix-blake2-detection.patch

+ 1
- 1
lang/python/python3-version.mk View File

@ -8,7 +8,7 @@
# Note: keep in sync with setuptools & pip
PYTHON3_VERSION_MAJOR:=3
PYTHON3_VERSION_MINOR:=8
PYTHON3_VERSION_MICRO:=0
PYTHON3_VERSION_MICRO:=1
PYTHON3_VERSION:=$(PYTHON3_VERSION_MAJOR).$(PYTHON3_VERSION_MINOR)


+ 2
- 2
lang/python/python3/Makefile View File

@ -14,12 +14,12 @@ PYTHON_VERSION:=$(PYTHON3_VERSION)
PYTHON_VERSION_MICRO:=$(PYTHON3_VERSION_MICRO)
PKG_NAME:=python3
PKG_RELEASE:=3
PKG_RELEASE:=1
PKG_VERSION:=$(PYTHON_VERSION).$(PYTHON_VERSION_MICRO)
PKG_SOURCE:=Python-$(PKG_VERSION).tar.xz
PKG_SOURCE_URL:=https://www.python.org/ftp/python/$(PKG_VERSION)
PKG_HASH:=b356244e13fb5491da890b35b13b2118c3122977c2cd825e3eb6e7d462030d84
PKG_HASH:=75894117f6db7051c1b34f37410168844bbb357c139a8a10a352e9bf8be594e8
PKG_MAINTAINER:=Alexandru Ardelean <ardeleanalex@gmail.com>, Jeffery To <jeffery.to@gmail.com>
PKG_LICENSE:=Python/2.0


+ 0
- 11
lang/python/python3/patches/002-fix-blake2-detection.patch View File

@ -1,11 +0,0 @@
--- a/Modules/_hashopenssl.c
+++ b/Modules/_hashopenssl.c
@@ -42,7 +42,7 @@
#define PY_OPENSSL_HAS_SHAKE 1
#endif
-#ifdef NID_blake2b512
+#if defined(NID_blake2b512) && !defined(OPENSSL_NO_BLAKE2)
#define PY_OPENSSL_HAS_BLAKE2 1
#endif

Loading…
Cancel
Save