This website works better with JavaScript.
Home
Help
Sign In
LILiK
/
openwrt-packages-dist
Watch
5
Star
0
Fork
0
Code
Issues
0
Pull Requests
0
Projects
0
Releases
0
Wiki
Activity
Browse Source
Merge pull request
#915
from Zokormazo/grep
grep: Fix CVE-2015-1345 heap buffer overrun
lilik-openwrt-22.03
Jo-Philipp Wich
10 years ago
parent
38ae2398c2
e0edca76da
commit
d24359b730
2 changed files
with
16 additions
and
1 deletions
Split View
Diff Options
Show Stats
Download Patch File
Download Diff File
+1
-1
utils/grep/Makefile
+15
-0
utils/grep/patches/0001-grep-F-fix-a-heap-buffer-read-overrun.patch
+ 1
- 1
utils/grep/Makefile
View File
@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME
:=
grep
PKG_VERSION
:=
2.21
PKG_RELEASE
:=
1
PKG_RELEASE
:=
2
PKG_SOURCE
:=
$(
PKG_NAME
)
-
$(
PKG_VERSION
)
.tar.xz
PKG_SOURCE_URL
:=
@GNU/grep
+ 15
- 0
utils/grep/patches/0001-grep-F-fix-a-heap-buffer-read-overrun.patch
View File
@ -0,0 +1,15 @@
diff --git a/src/kwset.c b/src/kwset.c
index 4003c8d..376f7c3 100644
--- a/src/kwset.c
+++ b/src/kwset.c
@@ -643,6 +643,8 @@ bmexec_trans (kwset_t kwset, char const *text, size_t size)
if (! tp)
return -1;
tp++;
+ if (ep <= tp)
+ break;
}
}
}
--
cgit v0.9.0.2
Write
Preview
Loading…
Cancel
Save