|
|
@ -1,6 +1,6 @@ |
|
|
|
--- a/configure.ac
|
|
|
|
+++ b/configure.ac
|
|
|
|
@@ -137,6 +137,7 @@ ARG_DISBL_SET([fips-prf], [disable
|
|
|
|
@@ -146,6 +146,7 @@ ARG_DISBL_SET([fips-prf], [disable
|
|
|
|
ARG_ENABL_SET([gcm], [enables the GCM AEAD wrapper crypto plugin.]) |
|
|
|
ARG_ENABL_SET([gcrypt], [enables the libgcrypt plugin.]) |
|
|
|
ARG_DISBL_SET([gmp], [disable GNU MP (libgmp) based crypto implementation plugin.]) |
|
|
@ -8,7 +8,7 @@ |
|
|
|
ARG_DISBL_SET([curve25519], [disable Curve25519 Diffie-Hellman plugin.]) |
|
|
|
ARG_DISBL_SET([hmac], [disable HMAC crypto implementation plugin.]) |
|
|
|
ARG_ENABL_SET([md4], [enable MD4 software implementation plugin.]) |
|
|
|
@@ -1434,6 +1435,7 @@ ADD_PLUGIN([botan], [s ch
|
|
|
|
@@ -1454,6 +1455,7 @@ ADD_PLUGIN([botan], [s ch
|
|
|
|
ADD_PLUGIN([af-alg], [s charon scepclient pki scripts medsrv attest nm cmd aikgen]) |
|
|
|
ADD_PLUGIN([fips-prf], [s charon nm cmd]) |
|
|
|
ADD_PLUGIN([gmp], [s charon scepclient pki scripts manager medsrv attest nm cmd aikgen fuzz]) |
|
|
@ -16,7 +16,7 @@ |
|
|
|
ADD_PLUGIN([curve25519], [s charon pki scripts nm cmd]) |
|
|
|
ADD_PLUGIN([agent], [s charon nm cmd]) |
|
|
|
ADD_PLUGIN([keychain], [s charon cmd]) |
|
|
|
@@ -1575,6 +1577,7 @@ AM_CONDITIONAL(USE_SHA3, test x$sha3 = x
|
|
|
|
@@ -1595,6 +1597,7 @@ AM_CONDITIONAL(USE_SHA3, test x$sha3 = x
|
|
|
|
AM_CONDITIONAL(USE_MGF1, test x$mgf1 = xtrue) |
|
|
|
AM_CONDITIONAL(USE_FIPS_PRF, test x$fips_prf = xtrue) |
|
|
|
AM_CONDITIONAL(USE_GMP, test x$gmp = xtrue) |
|
|
@ -24,7 +24,7 @@ |
|
|
|
AM_CONDITIONAL(USE_CURVE25519, test x$curve25519 = xtrue) |
|
|
|
AM_CONDITIONAL(USE_RDRAND, test x$rdrand = xtrue) |
|
|
|
AM_CONDITIONAL(USE_AESNI, test x$aesni = xtrue) |
|
|
|
@@ -1851,6 +1854,7 @@ AC_CONFIG_FILES([
|
|
|
|
@@ -1872,6 +1875,7 @@ AC_CONFIG_FILES([
|
|
|
|
src/libstrongswan/plugins/mgf1/Makefile |
|
|
|
src/libstrongswan/plugins/fips_prf/Makefile |
|
|
|
src/libstrongswan/plugins/gmp/Makefile |
|
|
|