Browse Source

forked-daapd: fix compilation with GCC10

Signed-off-by: Rosen Penev <rosenp@gmail.com>
lilik-openwrt-22.03
Rosen Penev 4 years ago
parent
commit
d198307fd4
No known key found for this signature in database GPG Key ID: 36D31CFA845F0E3B
2 changed files with 21 additions and 1 deletions
  1. +1
    -1
      sound/forked-daapd/Makefile
  2. +20
    -0
      sound/forked-daapd/patches/020-gcc10.patch

+ 1
- 1
sound/forked-daapd/Makefile View File

@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=forked-daapd
PKG_VERSION:=27.1
PKG_RELEASE:=2
PKG_RELEASE:=3
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
PKG_SOURCE_URL:=https://github.com/ejurgensen/$(PKG_NAME)/releases/download/$(PKG_VERSION)/


+ 20
- 0
sound/forked-daapd/patches/020-gcc10.patch View File

@ -0,0 +1,20 @@
--- a/src/outputs.h
+++ b/src/outputs.h
@@ -185,7 +185,7 @@ struct output_data
int samples;
};
-struct output_buffer
+static struct output_buffer
{
struct timespec pts;
// The array is two larger than max quality subscriptions because element 0
@@ -262,7 +262,7 @@ struct output_definition
};
// Our main list of devices, not for use by backend modules
-struct output_device *output_device_list;
+static struct output_device *output_device_list;
/* ------------------------------- General use ------------------------------ */

Loading…
Cancel
Save