Browse Source

collectd: avoid libcap dependency

Buildbot revealed that Collectd 5.7.1 uses libcap to evaluate system
capabilities and display advice on some plugins (dns, iptables, exec,
ping, ceph, turbostat).

Disable the check in configure.ac in order to avoid a dependency
for libcap. (It is not that big, only 6 kB .ipk, but still avoid that.)

Signed-off-by: Hannu Nyman <hannu.nyman@iki.fi>
lilik-openwrt-22.03
Hannu Nyman 8 years ago
parent
commit
d1441d0424
1 changed files with 14 additions and 0 deletions
  1. +14
    -0
      utils/collectd/patches/700-disable-sys-capability-check.patch

+ 14
- 0
utils/collectd/patches/700-disable-sys-capability-check.patch View File

@ -0,0 +1,14 @@
--- a/configure.ac
+++ b/configure.ac
@@ -833,10 +833,7 @@
have_cpuid_h="no"
AC_CHECK_HEADERS(cpuid.h, [have_cpuid_h="yes"])
-have_capability="yes"
-AC_CHECK_HEADERS(sys/capability.h,
- [have_capability="yes"],
- [have_capability="no (<sys/capability.h> not found)"])
+have_capability="no"
if test "x$have_capability" = "xyes"; then
AC_CHECK_LIB(cap, cap_get_bound,
[have_capability="yes"],

Loading…
Cancel
Save