Browse Source

hfsprogs: fix compile with newer musl

Signed-off-by: Rosen Penev <rosenp@gmail.com>
lilik-openwrt-22.03
Rosen Penev 5 years ago
parent
commit
d0a4d12d6d
No known key found for this signature in database GPG Key ID: 36D31CFA845F0E3B
2 changed files with 36 additions and 8 deletions
  1. +6
    -8
      utils/hfsprogs/Makefile
  2. +30
    -0
      utils/hfsprogs/patches/020-cdefs.patch

+ 6
- 8
utils/hfsprogs/Makefile View File

@ -9,18 +9,16 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=hfsprogs PKG_NAME:=hfsprogs
PKG_VERSION:=332.25 PKG_VERSION:=332.25
PKG_RELEASE:=3
PKG_LICENSE:=GPL-3.0-or-later
PKG_LICENSE_FILES:=COPYING
PKG_MAINTAINER:=
PKG_RELEASE:=2
PKG_SOURCE:=$(PKG_NAME)_$(PKG_VERSION).orig.tar.gz PKG_SOURCE:=$(PKG_NAME)_$(PKG_VERSION).orig.tar.gz
PKG_SOURCE_URL:=http://archive.ubuntu.com/ubuntu/pool/universe/h/$(PKG_NAME) PKG_SOURCE_URL:=http://archive.ubuntu.com/ubuntu/pool/universe/h/$(PKG_NAME)
PKG_BUILD_DIR:=$(BUILD_DIR)/diskdev_cmds-$(PKG_VERSION)
PKG_HASH:=74c9aeca899ed7f4bf155c65fc45bf0f250c0f6d57360ea953b1d536d9aa45e6 PKG_HASH:=74c9aeca899ed7f4bf155c65fc45bf0f250c0f6d57360ea953b1d536d9aa45e6
PKG_LICENSE:=APSL 2.0
PKG_BUILD_DIR:=$(BUILD_DIR)/diskdev_cmds-$(PKG_VERSION)
PKG_MAINTAINER:=
PKG_LICENSE:=APSL-2.0
PKG_LICENSE_FILES:=COPYING
include $(INCLUDE_DIR)/package.mk include $(INCLUDE_DIR)/package.mk
include $(INCLUDE_DIR)/nls.mk include $(INCLUDE_DIR)/nls.mk


+ 30
- 0
utils/hfsprogs/patches/020-cdefs.patch View File

@ -0,0 +1,30 @@
--- a/fsck_hfs.tproj/fsck_hfs.h
+++ b/fsck_hfs.tproj/fsck_hfs.h
@@ -24,6 +24,7 @@
#include "cache.h"
+#include <sys/cdefs.h>
const extern char *cdevname; /* name of device being checked */
extern char *progname;
--- a/newfs_hfs.tproj/makehfs.c
+++ b/newfs_hfs.tproj/makehfs.c
@@ -28,6 +28,7 @@
*/
+#include <sys/cdefs.h>
#include <sys/param.h>
#include <sys/types.h>
#include <sys/time.h>
--- a/newfs_hfs.tproj/newfs_hfs.c
+++ b/newfs_hfs.tproj/newfs_hfs.c
@@ -34,6 +34,7 @@
#include <syslog.h>
#include <unistd.h>
+#include <sys/cdefs.h>
#include <sys/ioctl.h>
#include <sys/mount.h>
#include <sys/param.h>

Loading…
Cancel
Save