Browse Source

flashrom: include io.h to fix compile error

This patch includes sys/io.h from flash.h to fix compile errors

Signed-off-by: Rob Mosher <nyt-openwrt@countercultured.net>
lilik-openwrt-22.03
notnyt 9 years ago
parent
commit
d01dfdebcf
2 changed files with 13 additions and 1 deletions
  1. +1
    -1
      utils/flashrom/Makefile
  2. +12
    -0
      utils/flashrom/patches/0003-fix-io-h-include.patch

+ 1
- 1
utils/flashrom/Makefile View File

@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=flashrom
PKG_VERSION:=0.9.8
PKG_RELEASE:=5
PKG_RELEASE:=6
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
PKG_SOURCE_URL:=http://download.flashrom.org/releases


+ 12
- 0
utils/flashrom/patches/0003-fix-io-h-include.patch View File

@ -0,0 +1,12 @@
diff -uprN a/linux_spi.c b/linux_spi.c
--- a/flash.h 2015-02-08 16:57:52.000000000 -0500
+++ b/flash.h 2016-01-08 20:09:51.599387507 -0500
@@ -30,6 +30,7 @@
#include <stdio.h>
#include <stdint.h>
#include <stddef.h>
+#include <sys/io.h>
#include <stdbool.h>
#if IS_WINDOWS
#include <windows.h>

Loading…
Cancel
Save