|
|
@ -0,0 +1,15 @@ |
|
|
|
diff --git a/setup.py b/setup.py
|
|
|
|
index 7868b7b..544fa7e 100644
|
|
|
|
--- a/setup.py
|
|
|
|
+++ b/setup.py
|
|
|
|
@@ -452,8 +452,9 @@ class PyBuildExt(build_ext):
|
|
|
|
# directly since an inconsistently reproducible issue comes up where |
|
|
|
# the environment variable is not set even though the value were passed |
|
|
|
# into configure and stored in the Makefile (issue found on OS X 10.3). |
|
|
|
+ rt_lib_dirs = [] if cross_compiling else self.compiler.runtime_library_dirs
|
|
|
|
for env_var, arg_name, dir_list in ( |
|
|
|
- ('LDFLAGS', '-R', self.compiler.runtime_library_dirs),
|
|
|
|
+ ('LDFLAGS', '-R', rt_lib_dirs),
|
|
|
|
('LDFLAGS', '-L', self.compiler.library_dirs), |
|
|
|
('CPPFLAGS', '-I', self.compiler.include_dirs)): |
|
|
|
env_val = sysconfig.get_config_var(env_var) |