Browse Source

luasec: Replace -fPIC with $(FPIC)

Currently i386 and the PPC targets have issues linking issues.

https://github.com/openwrt/packages/issues/3319

says that replacing -fPIC with -fpic works.

Patch added to avoid package overriding settings set by toolchain and make
compilation less noisy

Signed-off-by: Rosen Penev <rosenp@gmail.com>
lilik-openwrt-22.03
Rosen Penev 6 years ago
parent
commit
cf23dd2eb0
No known key found for this signature in database GPG Key ID: 36D31CFA845F0E3B
2 changed files with 15 additions and 3 deletions
  1. +4
    -1
      lang/luasec/Makefile
  2. +11
    -2
      lang/luasec/patches/100-fix-compilation.patch

+ 4
- 1
lang/luasec/Makefile View File

@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=luasec
PKG_VERSION:=0.7
PKG_RELEASE:=1
PKG_RELEASE:=2
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=https://codeload.github.com/brunoos/luasec/tar.gz/luasec-$(PKG_VERSION)?
@ -41,6 +41,9 @@ endef
define Build/Configure
endef
TARGET_CFLAGS += $(FPIC)
TARGET_LDFLAGS += $(FPIC)
MAKE_FLAGS += \
INCDIR="$(TARGET_CPPFLAGS) -I." \
LIBDIR="$(TARGET_LDFLAGS) -L./luasocket" \


+ 11
- 2
lang/luasec/patches/100-fix-compilation.patch View File

@ -1,7 +1,16 @@
diff --git a/src/Makefile b/src/Makefile
index 9be2f14..93d1dc4 100644
--- a/src/Makefile
+++ b/src/Makefile
@@ -15,8 +15,8 @@ WARN=-Wall -pedantic
BSD_CFLAGS=-O2 -fPIC $(WARN) $(INCDIR) $(DEFS)
BSD_LDFLAGS=-O -fPIC -shared $(LIBDIR)
-LNX_CFLAGS=-O2 -fPIC $(WARN) $(INCDIR) $(DEFS)
-LNX_LDFLAGS=-O -fPIC -shared $(LIBDIR)
+LNX_CFLAGS=$(INCDIR) $(DEFS)
+LNX_LDFLAGS=-shared $(LIBDIR)
MAC_ENV=env MACOSX_DEPLOYMENT_TARGET='$(MACVER)'
MAC_CFLAGS=-O2 -fno-common $(WARN) $(INCDIR) $(DEFS)
@@ -33,10 +33,10 @@ LDFLAGS += $(MYLDFLAGS)
all:


Loading…
Cancel
Save