Browse Source

Merge pull request #12386 from neheb/kisme

kismet: fix compilation with libcxx 10
lilik-openwrt-22.03
Rosen Penev 4 years ago
committed by GitHub
parent
commit
ce21a8b488
No known key found for this signature in database GPG Key ID: 4AEE18F83AFDEB23
2 changed files with 12 additions and 1 deletions
  1. +1
    -1
      net/kismet/Makefile
  2. +11
    -0
      net/kismet/patches/030-libcxx.patch

+ 1
- 1
net/kismet/Makefile View File

@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=kismet
PKG_VERSION:=2016-07-R1
PKG_RELEASE:=3
PKG_RELEASE:=4
PKG_LICENSE:=LGPLv2.1
PKG_CPE_ID:=cpe:/a:kismet:kismet


+ 11
- 0
net/kismet/patches/030-libcxx.patch View File

@ -1,3 +1,14 @@
--- a/ipc_remote.cc
+++ b/ipc_remote.cc
@@ -914,7 +914,7 @@ int RootIPCRemote::OpenFDPassSock() {
return -1;
}
- if (bind(ipc_fd_fd, (const struct sockaddr *) &unixsock, sizeof(unixsock))) {
+ if (::bind(ipc_fd_fd, (const struct sockaddr *) &unixsock, sizeof(unixsock))) {
close(ipc_fd_fd);
_MSG("Failed to bind socket to pass file descriptors: " +
string(strerror(errno)), MSGFLAG_ERROR);
--- a/packetsource_wext.cc
+++ b/packetsource_wext.cc
@@ -405,7 +405,7 @@ void PacketSource_Wext::OpenWpaSupplicant() {


Loading…
Cancel
Save