Browse Source

wsdd2: fix invalid error message

* fixed invalid error message

Signed-off-by: Andy Walsh <andy.walsh44+github@gmail.com>
lilik-openwrt-22.03
Andy Walsh 6 years ago
parent
commit
cde778a70a
2 changed files with 11 additions and 8 deletions
  1. +1
    -1
      net/wsdd2/Makefile
  2. +10
    -7
      net/wsdd2/patches/001-add_uuid_boot_id.patch

+ 1
- 1
net/wsdd2/Makefile View File

@ -1,7 +1,7 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=wsdd2
PKG_RELEASE:=1
PKG_RELEASE:=2
PKG_SOURCE_PROTO:=git
PKG_SOURCE_URL:=https://github.com/Andy2244/wsdd2.git


+ 10
- 7
net/wsdd2/patches/001-add_uuid_boot_id.patch View File

@ -1,16 +1,19 @@
--- a/wsd.c 2018-07-20
+++ b/wsd.c 2018-07-20
@@ -97,12 +97,17 @@ static void uuid_endpoint(char *uuid, si
--- a/wsd.c 2018-07-24
+++ b/wsd.c 2018-09-10
@@ -96,13 +96,19 @@ static void uuid_endpoint(char *uuid, si
{
FILE *fp = fopen("/etc/machine-id", "r");
int c, i = 0;
+
+ if (!fp) {
+ DEBUG(0, W, "Can't open '/etc/machine-id', trying '/proc/sys/kernel/random/boot_id'");
+ fp = fopen("/proc/sys/kernel/random/boot_id", "r");
+ }
+
if (!fp)
- if (!fp)
+ if (!fp) {
+ DEBUG(0, W, "Can't open required '/etc/machine-id' or '/proc/sys/kernel/random/boot_id'");
return;
+ }
while (i < 36 && (c = getc(fp)) != EOF &&
- (isdigit(c) || (islower(c) && isxdigit(c)))) {


Loading…
Cancel
Save