Browse Source

Merge pull request #2714 from jow-/tiff-ftell-fix

tiff: fix wrong declaration of ftell() compat macro
lilik-openwrt-22.03
Jiri Slachta 8 years ago
parent
commit
cc23ad6aea
2 changed files with 12 additions and 1 deletions
  1. +1
    -1
      libs/tiff/Makefile
  2. +11
    -0
      libs/tiff/patches/005-fix-ftell-macro.patch

+ 1
- 1
libs/tiff/Makefile View File

@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=tiff
PKG_VERSION:=4.0.6
PKG_RELEASE:=1
PKG_RELEASE:=2
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=http://download.osgeo.org/libtiff


+ 11
- 0
libs/tiff/patches/005-fix-ftell-macro.patch View File

@ -0,0 +1,11 @@
--- a/libtiff/tiffiop.h
+++ b/libtiff/tiffiop.h
@@ -284,7 +284,7 @@ struct tiff {
*/
#if defined(HAVE_FSEEKO)
# define fseek(stream,offset,whence) fseeko(stream,offset,whence)
-# define ftell(stream,offset,whence) ftello(stream,offset,whence)
+# define ftell(stream) ftello(stream)
#endif
#endif
#if defined(__WIN32__) && \

Loading…
Cancel
Save