|
|
@ -1,6 +1,6 @@ |
|
|
|
--- a/configure.ac
|
|
|
|
+++ b/configure.ac
|
|
|
|
@@ -504,9 +504,9 @@ have_ioloop=no
|
|
|
|
@@ -488,9 +488,9 @@ have_ioloop=no
|
|
|
|
|
|
|
|
if test "$ioloop" = "best" || test "$ioloop" = "epoll"; then |
|
|
|
AC_CACHE_CHECK([whether we can use epoll],i_cv_epoll_works,[ |
|
|
@ -12,7 +12,7 @@ |
|
|
|
int main() |
|
|
|
{ |
|
|
|
return epoll_create(5) < 1; |
|
|
|
@@ -639,7 +639,7 @@ fi
|
|
|
|
@@ -594,7 +594,7 @@ fi
|
|
|
|
dnl * Old glibcs have broken posix_fallocate(). Make sure not to use it. |
|
|
|
dnl * It may also be broken in AIX. |
|
|
|
AC_CACHE_CHECK([whether posix_fallocate() works],i_cv_posix_fallocate_works,[ |
|
|
@ -21,7 +21,7 @@ |
|
|
|
#define _XOPEN_SOURCE 600 |
|
|
|
#include <stdio.h> |
|
|
|
#include <stdlib.h> |
|
|
|
@@ -648,6 +648,7 @@ AC_CACHE_CHECK([whether posix_fallocate(
|
|
|
|
@@ -603,6 +603,7 @@ AC_CACHE_CHECK([whether posix_fallocate(
|
|
|
|
#if defined(__GLIBC__) && (__GLIBC__ < 2 || __GLIBC_MINOR__ < 7) |
|
|
|
possibly broken posix_fallocate |
|
|
|
#endif |
|
|
|