Browse Source
ykpers: fix compilation with GCC10
Signed-off-by: Rosen Penev <rosenp@gmail.com>
lilik-openwrt-22.03
Rosen Penev
4 years ago
No known key found for this signature in database
GPG Key ID: 36D31CFA845F0E3B
2 changed files with
14 additions and
1 deletions
-
utils/ykpers/Makefile
-
utils/ykpers/patches/010-gcc10.patch
|
|
@ -2,7 +2,7 @@ include $(TOPDIR)/rules.mk |
|
|
|
|
|
|
|
PKG_NAME:=ykpers |
|
|
|
PKG_VERSION:=1.20.0 |
|
|
|
PKG_RELEASE:=1 |
|
|
|
PKG_RELEASE:=2 |
|
|
|
|
|
|
|
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz |
|
|
|
PKG_SOURCE_URL:=https://developers.yubico.com/yubikey-personalization/Releases |
|
|
|
|
|
@ -0,0 +1,13 @@ |
|
|
|
--- a/ykpers-args.h
|
|
|
|
+++ b/ykpers-args.h
|
|
|
|
@@ -33,8 +33,8 @@
|
|
|
|
|
|
|
|
#include "ykpers.h" |
|
|
|
|
|
|
|
-const char *usage;
|
|
|
|
-const char *optstring;
|
|
|
|
+extern const char *usage;
|
|
|
|
+extern const char *optstring;
|
|
|
|
|
|
|
|
int args_to_config(int argc, char **argv, YKP_CONFIG *cfg, char *oathid, |
|
|
|
size_t oathid_len, const char **infname, |