Browse Source

Merge pull request #13627 from neheb/pdnsrr

pdns-recursor: update to 4.3.4
lilik-openwrt-22.03
Rosen Penev 4 years ago
committed by GitHub
parent
commit
cb2b03a719
No known key found for this signature in database GPG Key ID: 4AEE18F83AFDEB23
5 changed files with 25 additions and 10 deletions
  1. +10
    -5
      net/pdns-recursor/Makefile
  2. +1
    -1
      net/pdns-recursor/patches/100-disable-recursor.conf-dist.patch
  3. +3
    -3
      net/pdns-recursor/patches/200-boost_thread_fix.patch
  4. +1
    -1
      net/pdns-recursor/patches/300-boost-173.patch
  5. +10
    -0
      net/pdns-recursor/patches/400-openssl-deprecated.patch

+ 10
- 5
net/pdns-recursor/Makefile View File

@ -1,21 +1,22 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=pdns-recursor
PKG_VERSION:=4.2.2
PKG_VERSION:=4.3.4
PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
PKG_SOURCE_URL:=https://downloads.powerdns.com/releases/
PKG_HASH:=9502de8ab7dde3fe5ecb3dea0f6dd8f9c96ca5e09b06f3d58d2f123abf6f7204
PKG_HASH:=38dd6935830d9e9f14f6cb53f88914bab09e50e57ac8aed5b5b9a4386d8328d1
PKG_MAINTAINER:=James Taylor <james@jtaylor.id.au>
PKG_LICENCE:=GPL-2.0-only
PKG_LICENCE_FILES:=COPYING
PKG_CPE_ID:=cpe:/a:powerdns:recursor
PKG_INSTALL:=1
PKG_FIXUP:=autoreconf
PKG_INSTALL:=1
PKG_BUILD_PARALLEL:=1
PKG_BUILD_DEPENDS:=protobuf/host
include $(INCLUDE_DIR)/package.mk
@ -25,7 +26,7 @@ define Package/pdns-recursor
SUBMENU:=IP Addresses and Names
USERID:=pdns:pdns
TITLE:=PowerDNS Recursor
DEPENDS:=+boost +boost-context +libatomic +liblua +libopenssl +protobuf
DEPENDS:=+boost +boost-context +boost-filesystem +libatomic +liblua +libopenssl +protobuf
URL:=https://www.powerdns.com/recursor.html
endef
@ -39,7 +40,7 @@ define Package/pdns-recursor/conffiles
/etc/init.d/pdns-recursor
endef
CONFIGURE_ARGS+= \
CONFIGURE_ARGS += \
--sysconfdir=/etc/powerdns \
--with-lua=lua \
--without-libcap \
@ -48,6 +49,10 @@ CONFIGURE_ARGS+= \
--without-net-snmp \
--disable-silent-rules
CONFIGURE_VARS += \
boost_cv_lib_context=yes \
boost_cv_lib_context_LIBS=-lboost_context
define Package/pdns-recursor/install
$(INSTALL_DIR) $(1)/etc/powerdns
$(INSTALL_CONF) ./files/recursor.conf-dist $(1)/etc/powerdns/


+ 1
- 1
net/pdns-recursor/patches/100-disable-recursor.conf-dist.patch View File

@ -1,6 +1,6 @@
--- a/Makefile.am
+++ b/Makefile.am
@@ -357,12 +357,6 @@
@@ -444,12 +444,6 @@
pubsuffix.cc: $(srcdir)/effective_tld_names.dat
$(AM_V_GEN)./mkpubsuffixcc


+ 3
- 3
net/pdns-recursor/patches/200-boost_thread_fix.patch View File

@ -1,6 +1,6 @@
--- a/m4/boost.m4
+++ b/m4/boost.m4
@@ -667,12 +667,15 @@
@@ -671,12 +671,15 @@ LDFLAGS=$boost_filesystem_save_LDFLAGS
BOOST_DEFUN([Context],
[boost_context_save_LIBS=$LIBS
boost_context_save_LDFLAGS=$LDFLAGS
@ -20,5 +20,5 @@
+# LDFLAGS="$LDFLAGS $BOOST_THREAD_LDFLAGS"
+#fi
if test $boost_major_version -ge 161; then
BOOST_FIND_LIB([context], [$1],
if test $boost_major_version -ge 169; then

+ 1
- 1
net/pdns-recursor/patches/300-boost-173.patch View File

@ -11,7 +11,7 @@
string err;
--- a/ws-recursor.cc
+++ b/ws-recursor.cc
@@ -45,6 +45,7 @@
@@ -46,6 +46,7 @@
extern thread_local FDMultiplexer* t_fdm;


+ 10
- 0
net/pdns-recursor/patches/400-openssl-deprecated.patch View File

@ -0,0 +1,10 @@
--- a/opensslsigners.cc
+++ b/opensslsigners.cc
@@ -29,6 +29,7 @@
#if defined(HAVE_LIBCRYPTO_ED25519) || defined(HAVE_LIBCRYPTO_ED448)
#include <openssl/evp.h>
#endif
+#include <openssl/bn.h>
#include <openssl/sha.h>
#include <openssl/rand.h>
#include <openssl/rsa.h>

Loading…
Cancel
Save