Browse Source

Merge pull request #7894 from neheb/spoof

spoofer: Fix compilation without deprecated OpenSSL APIs
lilik-openwrt-22.03
Hannu Nyman 5 years ago
committed by GitHub
parent
commit
c82e79713c
No known key found for this signature in database GPG Key ID: 4AEE18F83AFDEB23
2 changed files with 14 additions and 1 deletions
  1. +1
    -1
      net/spoofer/Makefile
  2. +13
    -0
      net/spoofer/patches/010-openssl-deprecated.patch

+ 1
- 1
net/spoofer/Makefile View File

@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=spoofer
PKG_VERSION:=1.4.1
PKG_RELEASE:=1
PKG_RELEASE:=2
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=https://www.caida.org/projects/spoofer/downloads


+ 13
- 0
net/spoofer/patches/010-openssl-deprecated.patch View File

@ -0,0 +1,13 @@
--- a/prober/spoofer-prober.cc
+++ b/prober/spoofer-prober.cc
@@ -2135,8 +2135,10 @@ int main(int argc, char **argv) {
#endif
#ifdef HAVE_LIBSSL
if (enableTLS) {
+#if OPENSSL_VERSION_NUMBER < 0x10100000L
SSL_load_error_strings();
SSL_library_init();
+#endif
ssl_ctx = SSL_CTX_new(SSLv23_client_method());
if (!ssl_ctx) {
ssl_err("SSL_CTX_new() failed");

Loading…
Cancel
Save