Browse Source

minicom: fix compilation with GCC10

Signed-off-by: Rosen Penev <rosenp@gmail.com>
lilik-openwrt-22.03
Rosen Penev 4 years ago
parent
commit
c6212ea6e9
No known key found for this signature in database GPG Key ID: 36D31CFA845F0E3B
2 changed files with 31 additions and 1 deletions
  1. +1
    -1
      utils/minicom/Makefile
  2. +30
    -0
      utils/minicom/patches/200-gcc10.patch

+ 1
- 1
utils/minicom/Makefile View File

@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=minicom
PKG_VERSION:=2.7.1
PKG_RELEASE:=1
PKG_RELEASE:=2
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=https://alioth.debian.org/frs/download.php/file/4215


+ 30
- 0
utils/minicom/patches/200-gcc10.patch View File

@ -0,0 +1,30 @@
--- a/src/minicom.h
+++ b/src/minicom.h
@@ -109,13 +109,13 @@ EXTERN char *dial_tty; /* tty to use. */
EXTERN char *dial_name; /* System we're conneced to */
EXTERN char *dial_number; /* Number we've dialed. */
-EXTERN char *dial_user; /* Our username there */
-EXTERN char *dial_pass; /* Our password */
+extern char *dial_user; /* Our username there */
+extern char *dial_pass; /* Our password */
#ifdef USE_SOCKET
-EXTERN int portfd_is_socket; /* File descriptor is a unix socket */
-EXTERN int portfd_is_connected; /* 1 if the socket is connected */
-EXTERN struct sockaddr_un portfd_sock_addr; /* the unix socket address */
+extern int portfd_is_socket; /* File descriptor is a unix socket */
+extern int portfd_is_connected; /* 1 if the socket is connected */
+extern struct sockaddr_un portfd_sock_addr; /* the unix socket address */
#define portfd_connected ((portfd_is_socket && !portfd_is_connected) \
? -1 : portfd)
#else
@@ -141,7 +141,7 @@ EXTERN int sbcolor; /* Status Bar Background Color */
EXTERN int st_attr; /* Status Bar attributes. */
/* jl 04.09.97 conversion tables */
-EXTERN unsigned char vt_outmap[256], vt_inmap[256];
+extern unsigned char vt_outmap[256], vt_inmap[256];
/* MARK updated 02/17/95 - history buffer */
EXTERN int num_hist_lines; /* History buffer size */

Loading…
Cancel
Save