Browse Source

python-libraries: Remove Python 2-only packages

These are either libraries that backport Python 3 features for Python 2
programs, or libraries that have not had Python 3 variants added to them
by anyone.

These packages will be added to the abandoned packages feed.

Signed-off-by: Jeffery To <jeffery.to@gmail.com>
lilik-openwrt-22.03
Jeffery To 5 years ago
parent
commit
c37b15e1c4
17 changed files with 0 additions and 799 deletions
  1. +0
    -49
      lang/python/python-crcmod/Makefile
  2. +0
    -47
      lang/python/python-dpkt/Makefile
  3. +0
    -47
      lang/python/python-egenix-mx-base/Makefile
  4. +0
    -52
      lang/python/python-enum34/Makefile
  5. +0
    -18
      lang/python/python-enum34/patches/001-omit-docs.patch
  6. +0
    -35
      lang/python/python-futures/Makefile
  7. +0
    -44
      lang/python/python-ipaddress/Makefile
  8. +0
    -57
      lang/python/python-ldap/Makefile
  9. +0
    -131
      lang/python/python-packages/Makefile
  10. +0
    -72
      lang/python/python-packages/README.md
  11. +0
    -45
      lang/python/python-pcapy/Makefile
  12. +0
    -13
      lang/python/python-pcapy/patches/010-libcxx.patch
  13. +0
    -55
      lang/python/python-psycopg2/Makefile
  14. +0
    -46
      lang/python/python-pyptlib/Makefile
  15. +0
    -52
      lang/python/python-txsocksx/Makefile
  16. +0
    -9
      lang/python/python-txsocksx/patches/001-omit-tests.patch
  17. +0
    -27
      lang/python/python-txsocksx/patches/002-do-not-use-vcversioner.patch

+ 0
- 49
lang/python/python-crcmod/Makefile View File

@ -1,49 +0,0 @@
#
# Copyright (C) 2015 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
#
include $(TOPDIR)/rules.mk
PKG_NAME:=python-crcmod
PKG_VERSION:=1.7
PKG_RELEASE:=1
PKG_MAINTAINER:=Micke Prag <micke.prag@telldus.se>
PKG_LICENSE:=MIT
PYPI_NAME:=crcmod
PKG_HASH:=dc7051a0db5f2bd48665a990d3ec1cc305a466a77358ca4492826f41f283601e
PKG_BUILD_DEPENDS:=python
include ../pypi.mk
include $(INCLUDE_DIR)/package.mk
include ../python-package.mk
define Package/python-crcmod
SUBMENU:=Python
SECTION:=lang
CATEGORY:=Languages
TITLE:=python-crcmod
URL:=http://crcmod.sourceforge.net/
DEPENDS:=+python-light
endef
define Package/python-crcmod/description
The software in this package is a Python module for generating objects that compute the Cyclic Redundancy Check (CRC). There is no attempt in this package to explain how the CRC works. There are a number of resources on the web that give a good explanation of the algorithms. Just do a Google search for "crc calculation" and browse till you find what you need. Another resource can be found in chapter 20 of the book "Numerical Recipes in C" by Press et. al.
endef
define Build/Compile
$(call Build/Compile/PyMod,,install --prefix="$(PKG_INSTALL_DIR)/usr")
endef
define Package/python-crcmod/install
$(INSTALL_DIR) $(1)$(PYTHON_PKG_DIR)
$(CP) \
$(PKG_INSTALL_DIR)$(PYTHON_PKG_DIR)/* \
$(1)$(PYTHON_PKG_DIR)
endef
$(eval $(call BuildPackage,python-crcmod))

+ 0
- 47
lang/python/python-dpkt/Makefile View File

@ -1,47 +0,0 @@
#
# Copyright (C) 2017 Andrew McConachie
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
#
include $(TOPDIR)/rules.mk
PKG_NAME:=python-dpkt
PKG_VERSION:=1.9.2
PKG_RELEASE:=1
PYPI_NAME:=dpkt
PKG_HASH:=52a92ecd5ca04d5bd852bb11cb2eac4bbe38b42a7c472e0d950eeb9f82a81e54
PKG_MAINTAINER:=Andrew McConachie <andrew@depht.com>
PKG_LICENSE:=BSD-3-Clause
PKG_LICENSE_FILES:=LICENSE
include ../pypi.mk
include $(INCLUDE_DIR)/package.mk
include ../python-package.mk
define Package/python-dpkt
SECTION:=language-python
CATEGORY:=Languages
SUBMENU:=Python
TITLE:=python-dpkt
URL:=https://dpkt.readthedocs.io/en/latest/
DEPENDS:=+python
endef
define Package/python-dpkt/description
dpkt is a python module for fast, simple packet creation / parsing, with definitions for the basic TCP/IP protocols
https://pypi.python.org/pypi/dpkt
https://github.com/kbandla/dpkt
endef
define Build/Compile
$(call Build/Compile/PyMod,,\
install --prefix=/usr --root="$(PKG_INSTALL_DIR)" \
)
endef
$(eval $(call PyPackage,python-dpkt))
$(eval $(call BuildPackage,python-dpkt))

+ 0
- 47
lang/python/python-egenix-mx-base/Makefile View File

@ -1,47 +0,0 @@
#
# Copyright (C) 2015 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
#
include $(TOPDIR)/rules.mk
PKG_NAME:=python-egenix-mx-base
PKG_VERSION:=3.2.9
PKG_RELEASE:=4
PKG_SOURCE:=egenix-mx-base-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=https://downloads.egenix.com/python
PKG_HASH:=1c6b67688e7a231c6c1da09b7a6a2210745c3f2507bdda70e2639faedbf68977
PKG_BUILD_DIR:=$(BUILD_DIR)/egenix-mx-base-$(PKG_VERSION)
PKG_MAINTAINER:=Dmitry Trefilov <the-alien@live.ru>
PKG_LICENSE:=eGenix
PKG_LICENSE_FILES:=LICENSE COPYRIGHT
include $(INCLUDE_DIR)/package.mk
include ../python-package.mk
define Package/python-egenix-mx-base
SECTION:=lang
CATEGORY:=Languages
TITLE:=Egenix mxBase
SUBMENU:=Python
URL:=https://www.egenix.com/products/python/mxBase/
DEPENDS:=+python-light
VARIANT:=python
endef
define Package/python-egenix-mx-base/description
The eGenix.com mx Base Distribution for Python is a collection
of professional quality software tools which enhance Python's
usability in many important areas such as fast text searching,
date/time processing and high speed data types.
endef
PYTHON_PKG_SETUP_ARGS:=
$(eval $(call PyPackage,python-egenix-mx-base))
$(eval $(call BuildPackage,python-egenix-mx-base))
$(eval $(call BuildPackage,python-egenix-mx-base-src))

+ 0
- 52
lang/python/python-enum34/Makefile View File

@ -1,52 +0,0 @@
#
# Copyright (C) 2015-2018 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
#
include $(TOPDIR)/rules.mk
PKG_NAME:=python-enum34
PKG_VERSION:=1.1.10
PKG_RELEASE:=1
PYPI_NAME:=enum34
PKG_HASH:=cce6a7477ed816bd2542d03d53db9f0db935dd013b70f336a95c73979289f248
PKG_LICENSE:=BSD-3-Clause
PKG_LICENSE_FILES:=enum/LICENSE
PKG_MAINTAINER:=Jeffery To <jeffery.to@gmail.com>
PKG_CPE_ID:=cpe:/a:python:enum34
include ../pypi.mk
include $(INCLUDE_DIR)/package.mk
include ../python-package.mk
define Package/python-enum34/Default
SECTION:=lang
CATEGORY:=Languages
SUBMENU:=Python
TITLE:=Backported Python 3.4 enum
URL:=https://bitbucket.org/stoneleaf/enum34
endef
define Package/python-enum34
$(call Package/python-enum34/Default)
DEPENDS:=+PACKAGE_python-enum34:python-light
VARIANT:=python
endef
define Package/python-enum34/description
enum34 is the new Python stdlib enum module available in Python 3.4
backported for previous versions of Python from 2.4 to 3.3.
endef
define PyPackage/python-enum34/filespec
+|$(PYTHON_PKG_DIR)
-|$(PYTHON_PKG_DIR)/enum/test.py
endef
$(eval $(call PyPackage,python-enum34))
$(eval $(call BuildPackage,python-enum34))
$(eval $(call BuildPackage,python-enum34-src))

+ 0
- 18
lang/python/python-enum34/patches/001-omit-docs.patch View File

@ -1,18 +0,0 @@
--- a/setup.py
+++ b/setup.py
@@ -71,15 +71,6 @@ data = dict(
version='1.1.10',
url='https://bitbucket.org/stoneleaf/enum34',
packages=packages,
- package_data={
- 'enum' : [
- 'LICENSE',
- 'README',
- 'doc/enum.rst',
- 'doc/enum.pdf',
- 'test.py',
- ]
- },
license='BSD License',
description='Python 3.4 Enum backported to 3.3, 3.2, 3.1, 2.7, 2.6, 2.5, and 2.4',
long_description=long_desc,

+ 0
- 35
lang/python/python-futures/Makefile View File

@ -1,35 +0,0 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=futures
PKG_VERSION:=3.2.0
PKG_RELEASE:=1
PYPI_NAME:=$(PKG_NAME)
PKG_HASH:=9ec02aa7d674acb8618afb127e27fde7fc68994c0437ad759fa094a574adb265
PKG_MAINTAINER:=Daniel Danzberger <daniel@dd-wrt.com>
PKG_LICENSE:=MIT
include ../pypi.mk
include $(INCLUDE_DIR)/package.mk
include ../python-package.mk
define Package/python-futures
SUBMENU:=Python
SECTION:=lang
CATEGORY:=Languages
TITLE:=futures
URL:=https://github.com/agronholm/pythonfutures
DEPENDS:=+python
VARIANT:=python
endef
define Package/python-futures/description
This is a backport of the concurrent.futures standard library module to Python 2.
It should not be installed on Python 3, although there should be no harm in doing so,
as the standard library takes precedence over third party libraries.
endef
$(eval $(call PyPackage,python-futures))
$(eval $(call BuildPackage,python-futures))
$(eval $(call BuildPackage,python-futures-src))

+ 0
- 44
lang/python/python-ipaddress/Makefile View File

@ -1,44 +0,0 @@
#
# Copyright (C) 2015-2018 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
#
include $(TOPDIR)/rules.mk
PKG_NAME:=python-ipaddress
PKG_VERSION:=1.0.23
PKG_RELEASE:=1
PYPI_NAME:=ipaddress
PKG_HASH:=b7f8e0369580bb4a24d5ba1d7cc29660a4a6987763faf1d8a8046830e020e7e2
PKG_LICENSE:=Python-2.0
PKG_MAINTAINER:=Jeffery To <jeffery.to@gmail.com>
include ../pypi.mk
include $(INCLUDE_DIR)/package.mk
include ../python-package.mk
define Package/python-ipaddress/Default
SECTION:=lang
CATEGORY:=Languages
SUBMENU:=Python
TITLE:=Python 3.3+'s ipaddress
URL:=https://github.com/phihag/ipaddress
endef
define Package/python-ipaddress
$(call Package/python-ipaddress/Default)
DEPENDS:=+PACKAGE_python-ipaddress:python-light
VARIANT:=python
endef
define Package/python-ipaddress/description
Python 3.3+'s ipaddress for Python 2.6, 2.7, 3.2.
endef
$(eval $(call PyPackage,python-ipaddress))
$(eval $(call BuildPackage,python-ipaddress))
$(eval $(call BuildPackage,python-ipaddress-src))

+ 0
- 57
lang/python/python-ldap/Makefile View File

@ -1,57 +0,0 @@
#
# Copyright (C) 2016-2017 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
#
include $(TOPDIR)/rules.mk
PKG_NAME:=python-ldap
PKG_VERSION:=3.1.0
PKG_RELEASE:=1
PKG_MAINTAINER:=Dmitry Trefilov <the-alien@live.ru>
PKG_LICENSE:=Python-style
PKG_LICENSE_FILES:=LICENSE
PYPI_NAME:=$(PKG_NAME)
PKG_HASH:=41975e79406502c092732c57ef0c2c2eb318d91e8e765f81f5d4ab6c1db727c5
include ../pypi.mk
include $(INCLUDE_DIR)/package.mk
include ../python-package.mk
define Package/python-ldap
SUBMENU:=Python
SECTION:=lang
CATEGORY:=Languages
DEPENDS:=+libopenldap +python
TITLE:=Python modules for implementing LDAP clients
URL:=https://python-ldap.org/
endef
define Package/python-ldap/description
python-ldap provides an object-oriented API to access LDAP directory
servers from Python programs. Mainly it wraps the OpenLDAP 2.x libs
for that purpose. Additionally the package contains modules for
other LDAP-related stuff (e.g. processing LDIF, LDAPURLs, LDAPv3
schema, LDAPv3 extended operations and controls, etc.).
endef
define Build/Compile
$(call Build/Compile/PyMod,,build_ext \
--include-dirs="$(STAGING_DIR)/usr/include:$(STAGING_DIR)/usr/include/sasl" \
--library-dirs="$(STAGING_DIR)/usr/lib:$(STAGING_DIR)/usr/lib/sasl2" \
build_py \
install --prefix="$(PKG_INSTALL_DIR)/usr")
endef
define PyPackage/python-ldap/install
$(INSTALL_DIR) $(1)$(PYTHON_PKG_DIR)
$(CP) \
$(PKG_INSTALL_DIR)$(PYTHON_PKG_DIR)/* \
$(1)$(PYTHON_PKG_DIR)
endef
$(eval $(call PyPackage,python-ldap))
$(eval $(call BuildPackage,python-ldap))

+ 0
- 131
lang/python/python-packages/Makefile View File

@ -1,131 +0,0 @@
#
# Copyright (C) 2016 Yousong Zhou <yszhou4tech@gmail.com>
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
#
include $(TOPDIR)/rules.mk
PKG_NAME:=python-packages
PKG_VERSION:=1.0
PKG_RELEASE:=2
PKG_MAINTAINER:=Yousong Zhou <yszhou4tech@gmail.com>
#
# NOTE: move the host module installation to Host/Compile when
# HOST_CONFIG_DEPENDS is supported
#
# NOTE: PKG_CONFIG_DEPENDS cannot correctly track changes of string type config
# options, so you may want to do manual cleanup on config change.
#
PKG_CONFIG_DEPENDS:= \
CONFIG_PACKAGE_python-packages-list-host \
CONFIG_PACKAGE_python-packages-list \
CONFIG_PACKAGE_python-packages-list-cleanup \
CONFIG_PACKAGE_python-packages-envs \
CONFIG_PACKAGE_python-packages-extra-deps \
CONFIG_PACKAGE_python-packages-index-url \
CONFIG_PACKAGE_python-packages-pip-opts \
PKG_BUILD_DEPENDS:=python python/host
include $(INCLUDE_DIR)/package.mk
include ../python-package.mk
define Package/python-packages
SUBMENU:=Python
SECTION:=lang
CATEGORY:=Languages
TITLE:=A dummy package for packaging python modules with pip
DEPENDS:=@DEVEL +python
endef
define Package/python-packages/config
if PACKAGE_python-packages
config PACKAGE_python-packages-list-host
string "List of python packages to install on host"
config PACKAGE_python-packages-list
string "List of python packages to install on target"
config PACKAGE_python-packages-list-cleanup
string "List of python packages to cleanup to avoid clash with existing packages"
config PACKAGE_python-packages-envs
string "Extra environment variables to pass on to pip and its children on target build"
config PACKAGE_python-packages-extra-deps
string "List of deps fulfilled but not tracked by the build system"
config PACKAGE_python-packages-index-url
string "Index URL passed to pip with --index-url"
config PACKAGE_python-packages-pip-opts
string "Additional arguments to pip command line"
endif
endef
CONFIG_PACKAGE_python-packages-list-host:=$(call qstrip,$(CONFIG_PACKAGE_python-packages-list-host))
CONFIG_PACKAGE_python-packages-list:=$(call qstrip,$(CONFIG_PACKAGE_python-packages-list))
CONFIG_PACKAGE_python-packages-list-cleanup:=$(call qstrip,$(CONFIG_PACKAGE_python-packages-list-cleanup))
CONFIG_PACKAGE_python-packages-envs:=$(call qstrip,$(CONFIG_PACKAGE_python-packages-envs))
CONFIG_PACKAGE_python-packages-extra-deps:=$(call qstrip,$(CONFIG_PACKAGE_python-packages-extra-deps))
CONFIG_PACKAGE_python-packages-index-url:=$(call qstrip,$(CONFIG_PACKAGE_python-packages-index-url))
CONFIG_PACKAGE_python-packages-pip-opts:=$(call qstrip,$(CONFIG_PACKAGE_python-packages-pip-opts))
HOST_PYTHON_PIP:=$(STAGING_DIR_HOSTPKG)/bin/pip$(PYTHON_VERSION)
decr=$(word $(1),0 1 2 3 4 5 6 7 8 9 10)
recur=$(if $(subst 0,,$(2)),$(call recur,$(1),$(call decr,$(2)),$(call $(1)$(2),$(3))),$(3))
_req2dir1=$(subst >,gt,$(1))
_req2dir2=$(subst <,lt,$(1))
_req2dir3=$(subst >=,geq,$(1))
_req2dir4=$(subst <=,leq,$(1))
_req2dir5=$(subst ://,:::,$(1))
_req2dir6=$(subst *,_,$(1))
_req2dir7=$(subst ?,_,$(1))
req2dir=$(call recur,_req2dir,7,$(1))
# --ignore-installed, it may happen that host pip will ignore target install if
# it was already installed as host module, e.g. cffi deps of cryptograph
HOST_PYTHON_PIP_INSTALL=$(HOST_PYTHON_PIP) install \
--root=$(1) \
--prefix=$(2) \
--ignore-installed \
--no-compile \
$(if $(CONFIG_PACKAGE_python-packages-index-url), --index-url "$(CONFIG_PACKAGE_python-packages-index-url)") \
$(if $(CONFIG_PACKAGE_python-packages-pip-opts), $(CONFIG_PACKAGE_python-packages-pip-opts)) \
HOST_PYTHON_PIP_INSTALL_HOST:=$(call HOST_PYTHON_PIP_INSTALL,$(STAGING_DIR_HOSTPKG),"")
HOST_PYTHON_PIP_INSTALL_TARGET=$(call HOST_PYTHON_PIP_INSTALL,$(PKG_INSTALL_DIR)/$(call req2dir,$(pkg)),/usr)
HOST_PYTHON_PIP_INSTALL_CLEANUP:=$(call HOST_PYTHON_PIP_INSTALL,$(PKG_INSTALL_DIR)/_cleanup,/usr)
define Build/Compile
$(foreach pkg,$(CONFIG_PACKAGE_python-packages-list-host),
$(call Build/Compile/HostPyRunHost,,$(HOST_PYTHON_PIP_INSTALL_HOST) $(pkg))
)
$(foreach pkg,$(CONFIG_PACKAGE_python-packages-list),
$(call Build/Compile/HostPyRunTarget,,$(call HOST_PYTHON_PIP_INSTALL_TARGET,$(pkg)) $(pkg),$(CONFIG_PACKAGE_python-packages-envs))
)
$(foreach pkg,$(CONFIG_PACKAGE_python-packages-list-cleanup),
$(call Build/Compile/HostPyRunTarget,,$(HOST_PYTHON_PIP_INSTALL_CLEANUP) $(pkg),$(CONFIG_PACKAGE_python-packages-envs))
)
endef
define Package/python-packages/install
$(foreach pkg,$(CONFIG_PACKAGE_python-packages-list),
$(CP) "$(PKG_INSTALL_DIR)/$(call req2dir,$(pkg))"/* $(1)
)
find "$(PKG_INSTALL_DIR)/_cleanup" -mindepth 1 -depth | while read sf; do \
tf="$$$${sf#$(PKG_INSTALL_DIR)/_cleanup/}"; \
tf="$(1)/$$$$tf"; \
if [ -f "$$$$tf" -o -L "$$$$tf" ]; then \
rm -vf "$$$$tf"; \
elif [ -d "$$$$tf" ]; then \
rmdir -v -p "$$$$tf" || true; \
fi \
done
endef
define Package/python-packages/extra_provides
echo $(CONFIG_PACKAGE_python-packages-extra-deps) | tr ' ' '\n'
endef
$(eval $(call BuildPackage,python-packages))

+ 0
- 72
lang/python/python-packages/README.md View File

@ -1,72 +0,0 @@
This package allows users to package python modules without creating package
Makefiles for each individual module and their dependencies. It provides a
way making packaging python packages faster and may also facilitate the process
of developing Makefiles for new python packages
This is a raw DEVEL only package. Using it may entail a lot of implementation
details and you may need to resolve target dependencies and package details on
your own
- Third party python packages may depend on features not included in e.g.
python-light
- Some python modules may require host install of another module to progress,
e.g. target cryptography requires host cffi
- Some python modules have external C library dependencies, e.g. pyOpenSSL
requires openssl libs
- Some packages may have an autoconf configure script whose arguments we
cannot control with pip and has to be passed on (hacked) by overriding some
environment variables
## How it works
1. Install host modules required for building target modules
2. Install each target module to separate directories
3. Install another copy of modules for cleanup purposes to make list of
installed files to be removed from target modules installed in step 2
Why should it be so
1. Installing target cryptography requires host installation of cffi module
2. cryptography requires setuptools and pip will install its own copy with
--ignore-installed. When PACKAGE_python-setuptools is also selected, opkg
will complain of data file clashes if it was not removed here.
Pip will handle dependency requirements of python modules, but external
dependencies like c libraries has to be prepared by the build system. The
issue is that there is currently no way to express such dependencies, thus may
cause build failure, e.g. pycrypto requires the presence of libgmp to build
successfully.
## Tips
If something goes wrong, we can add additional arguments to pip command
line to check the detailed build process. Some useful arguments may be
- -v, for verbose output. Repeat this option if the current level of
verbosity is not enough
- --no-clean, for preserving pip build dir on build failure
## Examples
tornado (python-only module)
CONFIG_PACKAGE_python-packages=y
CONFIG_PACKAGE_python-packages-list="tornado==4.4.2"
cryptography (requires installation of host modules and cleanup on target modules)
CONFIG_PACKAGE_python-packages=y
CONFIG_PACKAGE_python-packages-list-host="cffi"
CONFIG_PACKAGE_python-packages-list="cryptography"
CONFIG_PACKAGE_python-packages-list-cleanup="setuptools"
pycrypto 2.7a1 (python module with autoconf configure script; depends on
libgmp; broken wmmintrin.h). 2.6.1 does not work because of a flaw in
the setup.py hardcoding host include directory
CONFIG_PACKAGE_libgmp=y
CONFIG_PACKAGE_python-packages=y
CONFIG_PACKAGE_python-packages-list="https://github.com/dlitz/pycrypto/archive/v2.7a1.tar.gz"
CONFIG_PACKAGE_python-packages-envs="ac_cv_header_wmmintrin_h=no build_alias=$(GNU_HOST_NAME) host_alias=$(GNU_TARGET_NAME) target_alias=$(GNU_TARGET_NAME)"
CONFIG_PACKAGE_python-packages-extra-deps="libgmp.so.10"

+ 0
- 45
lang/python/python-pcapy/Makefile View File

@ -1,45 +0,0 @@
#
# Copyright (C) 2016 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
#
include $(TOPDIR)/rules.mk
PKG_NAME:=python-pcapy
PKG_VERSION:=0.11.4
PKG_RELEASE:=2
PYPI_NAME:=pcapy
PKG_HASH:=aa239913678d7ba116e66057a37f914de7726aecd11d00db470127df115c4e78
PKG_MAINTAINER:=Andrew McConachie <andrew@depht.com>
PKG_LICENSE:=Apache-1.1
include ../pypi.mk
include $(INCLUDE_DIR)/uclibc++.mk
include $(INCLUDE_DIR)/package.mk
include ../python-package.mk
define Package/python-pcapy
SECTION:=language-python
CATEGORY:=Languages
SUBMENU:=Python
TITLE:=python-pcapy
URL:=https://www.coresecurity.com/corelabs-research/open-source-tools/pcapy
DEPENDS:=+python +libpcap $(CXX_DEPENDS)
endef
define Package/python-pcapy/description
Pcapy is a Python extension module that interfaces with the libpcap packet capture library. Pcapy enables python scripts to capture packets on the network. Pcapy is highly effective when used in conjunction with a packet-handling package such as Impacket, which is a collection of Python classes for constructing and dissecting network packets.
endef
define Build/Compile
$(call Build/Compile/PyMod,,\
install --prefix=/usr --root="$(PKG_INSTALL_DIR)" \
)
endef
$(eval $(call PyPackage,python-pcapy))
$(eval $(call BuildPackage,python-pcapy))

+ 0
- 13
lang/python/python-pcapy/patches/010-libcxx.patch View File

@ -1,13 +0,0 @@
diff --git a/setup.py b/setup.py
index 4da69bc..165059b 100644
--- a/setup.py
+++ b/setup.py
@@ -28,7 +28,7 @@ if sys.platform == 'win32':
library_dirs.append(r'c:\wpdpack\Lib')
libraries = ['wpcap', 'packet', 'ws2_32']
else:
- libraries = ['pcap', 'stdc++']
+ libraries = ['pcap']
# end of user configurable parameters

+ 0
- 55
lang/python/python-psycopg2/Makefile View File

@ -1,55 +0,0 @@
#
# Copyright (C) 2016 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
#
include $(TOPDIR)/rules.mk
PKG_NAME:=python-psycopg2
PKG_VERSION:=2.7.6.1
PKG_RELEASE:=2
PYPI_NAME:=psycopg2
PKG_HASH:=27959abe64ca1fc6d8cd11a71a1f421d8287831a3262bd4cacd43bbf43cc3c82
PKG_MAINTAINER:=Dmitry Trefilov <the-alien@live.ru>
PKG_LICENSE:=LGPL-3.0-or-later
PKG_LICENSE_FILES:=LICENSE
PKG_BUILD_DEPENDS:=python/host
include ../pypi.mk
include $(INCLUDE_DIR)/package.mk
include ../python-package.mk
define Package/python-psycopg2
SUBMENU:=Python
SECTION:=lang
CATEGORY:=Languages
TITLE:=PostgreSQL database adapter for Python
URL:=http://initd.org/psycopg/
DEPENDS:=+python +libpq +python-egenix-mx-base
endef
define Package/python-psycopg2/description
Psycopg is the most popular PostgreSQL adapter for the Python programming language
endef
define Build/Compile
# The PATH var is required so that psycopg2's setup.py script finds pg_config
$(call Build/Compile/PyMod,., \
install --prefix=/usr --root=$(PKG_INSTALL_DIR), \
PATH=$(STAGING_DIR)/usr/bin:$(PATH))
endef
define Package/python-psycopg2/install
$(INSTALL_DIR) $(1)$(PYTHON_PKG_DIR)
$(CP) \
$(PKG_INSTALL_DIR)$(PYTHON_PKG_DIR)/* \
$(1)$(PYTHON_PKG_DIR)
endef
$(eval $(call PyPackage,python-psycopg2))
$(eval $(call BuildPackage,python-psycopg2))

+ 0
- 46
lang/python/python-pyptlib/Makefile View File

@ -1,46 +0,0 @@
#
# Copyright (C) 2015, 2017-2018 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
#
include $(TOPDIR)/rules.mk
PKG_NAME:=python-pyptlib
PKG_VERSION:=0.0.6
PKG_RELEASE:=3
PYPI_NAME:=pyptlib
PKG_HASH:=b98472e3d9e8f4689d3913ca8f89afa5e6cc5383dcd8686987606166f9dac607
PKG_LICENSE:=BSD-3-Clause
PKG_LICENSE_FILES:=LICENSE
PKG_MAINTAINER:=Jeffery To <jeffery.to@gmail.com>
include ../pypi.mk
include $(INCLUDE_DIR)/package.mk
include ../python-package.mk
define Package/python-pyptlib/Default
SECTION:=lang
CATEGORY:=Languages
SUBMENU:=Python
TITLE:=Pluggable Transports for Tor
URL:=https://pypi.org/project/pyptlib/
endef
define Package/python-pyptlib
$(call Package/python-pyptlib/Default)
DEPENDS:=+PACKAGE_python-pyptlib:python-light
VARIANT:=python
endef
define Package/python-pyptlib/description
A python implementation of the Pluggable Transports for Circumvention
specification for Tor
endef
$(eval $(call PyPackage,python-pyptlib))
$(eval $(call BuildPackage,python-pyptlib))
$(eval $(call BuildPackage,python-pyptlib-src))

+ 0
- 52
lang/python/python-txsocksx/Makefile View File

@ -1,52 +0,0 @@
#
# Copyright (C) 2015, 2017-2018 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
#
include $(TOPDIR)/rules.mk
PKG_NAME:=python-txsocksx
PKG_VERSION:=1.15.0.2
PKG_RELEASE:=4
PYPI_NAME:=txsocksx
PKG_HASH:=4f79b5225ce29709bfcee45e6f726e65b70fd6f1399d1898e54303dbd6f8065f
PKG_LICENSE:=ISC
PKG_LICENSE_FILES:=COPYING
PKG_MAINTAINER:=Jeffery To <jeffery.to@gmail.com>
include ../pypi.mk
include $(INCLUDE_DIR)/package.mk
include ../python-package.mk
PYTHON_PKG_SETUP_VARS:= \
PKG_VERSION="$(PKG_VERSION)"
define Package/python-txsocksx/Default
SECTION:=lang
CATEGORY:=Languages
SUBMENU:=Python
TITLE:=SOCKS client endpoints for Twisted
URL:=https://github.com/habnabit/txsocksx
endef
define Package/python-txsocksx
$(call Package/python-txsocksx/Default)
DEPENDS:= \
+PACKAGE_python-txsocksx:python-light \
+PACKAGE_python-txsocksx:python-parsley \
+PACKAGE_python-txsocksx:python-twisted
VARIANT:=python
endef
define Package/python-txsocksx/description
txsocksx is SOCKS4/4a and SOCKS5 client endpoints for Twisted 10.1 or
greater.
endef
$(eval $(call PyPackage,python-txsocksx))
$(eval $(call BuildPackage,python-txsocksx))
$(eval $(call BuildPackage,python-txsocksx-src))

+ 0
- 9
lang/python/python-txsocksx/patches/001-omit-tests.patch View File

@ -1,9 +0,0 @@
--- a/setup.py
+++ b/setup.py
@@ -35,5 +35,5 @@ setup(
'version_module_paths': ['txsocksx/_version.py'],
},
install_requires=install_requires,
- packages=['txsocksx', 'txsocksx.test'],
+ packages=['txsocksx'],
)

+ 0
- 27
lang/python/python-txsocksx/patches/002-do-not-use-vcversioner.patch View File

@ -1,27 +0,0 @@
--- a/setup.py
+++ b/setup.py
@@ -1,6 +1,8 @@
# Copyright (c) Aaron Gallagher <_@habnab.it>
# See COPYING for details.
+import os
+
from setuptools import setup
@@ -30,10 +32,11 @@ setup(
],
license='ISC',
- setup_requires=['vcversioner>=1'],
- vcversioner={
- 'version_module_paths': ['txsocksx/_version.py'],
- },
+ #setup_requires=['vcversioner>=1'],
+ #vcversioner={
+ # 'version_module_paths': ['txsocksx/_version.py'],
+ #},
+ version=os.environ.get('PKG_VERSION'),
install_requires=install_requires,
packages=['txsocksx'],
)

Loading…
Cancel
Save