Browse Source

Merge pull request #10341 from gladiac1337/haproxy-2.0.8

haproxy: Update HAProxy to v2.0.8
lilik-openwrt-22.03
Rosen Penev 5 years ago
committed by GitHub
parent
commit
c3709af67a
No known key found for this signature in database GPG Key ID: 4AEE18F83AFDEB23
5 changed files with 3 additions and 30 deletions
  1. +2
    -2
      net/haproxy/Makefile
  2. +1
    -1
      net/haproxy/get-latest-patches.sh
  3. +0
    -27
      net/haproxy/patches/000-BUG-MINOR-stats-Add-a-missing-break-in-a-switch-statement.patch
  4. +0
    -0
      net/haproxy/patches/000-OPENWRT-add-uclibc-support.patch
  5. +0
    -0
      net/haproxy/patches/001-OPENWRT-openssl-deprecated.patch

+ 2
- 2
net/haproxy/Makefile View File

@ -10,12 +10,12 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=haproxy
PKG_VERSION:=2.0.7
PKG_VERSION:=2.0.8
PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=https://www.haproxy.org/download/2.0/src
PKG_HASH:=3873cd72028ed1bd2506dd174e01a92620e92683092f34234c96e067dcb113dc
PKG_HASH:=c37e1e8515ad6f9781a0ac336ca88787f3bb52252fb2bdad9919ba16323c280a
PKG_MAINTAINER:=Thomas Heil <heil@terminal-consulting.de>, \
Christian Lachner <gladiac@gmail.com>


+ 1
- 1
net/haproxy/get-latest-patches.sh View File

@ -1,7 +1,7 @@
#!/bin/sh
CLONEURL=https://git.haproxy.org/git/haproxy-2.0.git
BASE_TAG=v2.0.7
BASE_TAG=v2.0.8
TMP_REPODIR=tmprepo
PATCHESDIR=patches


+ 0
- 27
net/haproxy/patches/000-BUG-MINOR-stats-Add-a-missing-break-in-a-switch-statement.patch View File

@ -1,27 +0,0 @@
commit c0104fc33ccf7e843efd37cc033e4c3849a37844
Author: Christopher Faulet <cfaulet@haproxy.com>
Date: Sat Sep 28 10:37:31 2019 +0200
BUG/MINOR: stats: Add a missing break in a switch statement
A break is missing in the switch statement in the function
stats_emit_json_data_field(). This bug was introduced in the commit 88a0db28a
("MINOR: stats: Add the support of float fields in stats").
This patch fixes the issue #302 and #303. It must be backported to 2.0.
(cherry picked from commit 52c91bb72ccf20e75f2f79da6ebe345cb2a768f4)
Signed-off-by: Christopher Faulet <cfaulet@haproxy.com>
diff --git a/src/stats.c b/src/stats.c
index 5819f459..9ec5066f 100644
--- a/src/stats.c
+++ b/src/stats.c
@@ -399,6 +399,7 @@ int stats_emit_json_data_field(struct buffer *out, const struct field *f)
type = "\"u64\"";
snprintf(buf, sizeof(buf), "%llu",
(unsigned long long) f->u.u64);
+ break;
case FF_FLT: type = "\"flt\"";
snprintf(buf, sizeof(buf), "%f", f->u.flt);
break;

net/haproxy/patches/001-OPENWRT-add-uclibc-support.patch → net/haproxy/patches/000-OPENWRT-add-uclibc-support.patch View File


net/haproxy/patches/002-OPENWRT-openssl-deprecated.patch → net/haproxy/patches/001-OPENWRT-openssl-deprecated.patch View File


Loading…
Cancel
Save