Browse Source

gpsd: Add missing define

musl needs _BSD_SOURCE defined for strlcat/cpy

Signed-off-by: Rosen Penev <rosenp@gmail.com>
lilik-openwrt-22.03
Rosen Penev 5 years ago
parent
commit
c21b34e2cb
2 changed files with 41 additions and 1 deletions
  1. +1
    -1
      utils/gpsd/Makefile
  2. +40
    -0
      utils/gpsd/patches/010-musl.patch

+ 1
- 1
utils/gpsd/Makefile View File

@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=gpsd
PKG_VERSION:=3.17
PKG_RELEASE:=2
PKG_RELEASE:=3
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=@SAVANNAH/$(PKG_NAME)


+ 40
- 0
utils/gpsd/patches/010-musl.patch View File

@ -0,0 +1,40 @@
--- a/driver_ais.c
+++ b/driver_ais.c
@@ -24,6 +24,7 @@
/* strlcpy() needs _DARWIN_C_SOURCE */
#define _DARWIN_C_SOURCE
+#define _BSD_SOURCE
#include <stdlib.h>
#include <string.h>
--- a/gpsctl.c
+++ b/gpsctl.c
@@ -15,6 +15,7 @@
/* strlcpy() needs _DARWIN_C_SOURCE */
#define _DARWIN_C_SOURCE
+#define _BSD_SOURCE
#include <stdio.h>
#include <stdlib.h>
--- a/gpsd_json.c
+++ b/gpsd_json.c
@@ -24,6 +24,7 @@ PERMISSIONS
#define __DARWIN_C_LEVEL 200112L
/* strlcpy() needs _DARWIN_C_SOURCE */
#define _DARWIN_C_SOURCE
+#define _BSD_SOURCE
#include <stdio.h>
#include <math.h>
--- a/libgpsd_core.c
+++ b/libgpsd_core.c
@@ -20,6 +20,7 @@
/* strlcpy() needs _DARWIN_C_SOURCE */
#define _DARWIN_C_SOURCE
+#define _BSD_SOURCE
#include <time.h>
#include <stdio.h>

Loading…
Cancel
Save