Browse Source

Merge pull request #16422 from neheb/g19

gerbera: update to 1.9.0
lilik-openwrt-22.03
Rosen Penev 3 years ago
committed by GitHub
parent
commit
c02d128035
No known key found for this signature in database GPG Key ID: 4AEE18F83AFDEB23
4 changed files with 46 additions and 15 deletions
  1. +2
    -2
      libs/spdlog/Makefile
  2. +0
    -11
      libs/spdlog/patches/010-fmt8.patch
  3. +2
    -2
      multimedia/gerbera/Makefile
  4. +42
    -0
      multimedia/gerbera/patches/010-Os-unique_ptr.patch

+ 2
- 2
libs/spdlog/Makefile View File

@ -6,12 +6,12 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=spdlog
PKG_VERSION:=1.8.5
PKG_VERSION:=1.9.2
PKG_RELEASE:=$(AUTORELEASE)
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=https://codeload.github.com/gabime/spdlog/tar.gz/v$(PKG_VERSION)?
PKG_HASH:=944d0bd7c763ac721398dca2bb0f3b5ed16f67cef36810ede5061f35a543b4b8
PKG_HASH:=6fff9215f5cb81760be4cc16d033526d1080427d236e86d70bb02994f85e3d38
PKG_MAINTAINER:=
PKG_LICENSE:=MIT


+ 0
- 11
libs/spdlog/patches/010-fmt8.patch View File

@ -1,11 +0,0 @@
--- a/include/spdlog/common-inl.h
+++ b/include/spdlog/common-inl.h
@@ -60,7 +60,7 @@ SPDLOG_INLINE spdlog_ex::spdlog_ex(std::
SPDLOG_INLINE spdlog_ex::spdlog_ex(const std::string &msg, int last_errno)
{
memory_buf_t outbuf;
- fmt::format_system_error(outbuf, last_errno, msg);
+ fmt::format_system_error(outbuf, last_errno, msg.data());
msg_ = fmt::to_string(outbuf);
}

+ 2
- 2
multimedia/gerbera/Makefile View File

@ -8,12 +8,12 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=gerbera
PKG_VERSION:=1.8.2
PKG_VERSION:=1.9.0
PKG_RELEASE:=$(AUTORELEASE)
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=https://codeload.github.com/gerbera/gerbera/tar.gz/v$(PKG_VERSION)?
PKG_HASH:=b1e5591515f05a46de052ef4d95a2bb3387e96f565a5ce7abb6a77dbe581f09a
PKG_HASH:=7d3af525a6c37e10869961b2fedc2cfb54d8acf30256a2d5a10394c6a97ed25b
PKG_MAINTAINER:=
PKG_LICENSE:=GPL-2.0-or-later


+ 42
- 0
multimedia/gerbera/patches/010-Os-unique_ptr.patch View File

@ -0,0 +1,42 @@
From 7071316114b7d196808d943ce654b355927e73e1 Mon Sep 17 00:00:00 2001
From: Karlchen <k_straussberger@netzland.net>
Date: Mon, 23 Aug 2021 09:04:36 +0200
Subject: [PATCH] Fix linkage error in on aarch64 with g++-10
fixes #1674
---
src/content/content_manager.cc | 8 ++++----
1 file changed, 4 insertions(+), 4 deletions(-)
--- a/src/content/content_manager.cc
+++ b/src/content/content_manager.cc
@@ -622,17 +622,17 @@ void ContentManager::_rescanDirectory(co
std::error_code ec;
auto rootDir = fs::directory_entry(location, ec);
- fs::directory_iterator dIter;
+ std::unique_ptr<fs::directory_iterator> dIter;
if (!ec && rootDir.exists(ec) && rootDir.is_directory(ec)) {
- dIter = fs::directory_iterator(location, ec);
+ dIter = std::make_unique<fs::directory_iterator>(location, ec);
if (ec) {
log_error("_rescanDirectory: Failed to iterate {}, {}", location.c_str(), ec.message());
}
} else {
log_error("Could not open {}: {}", location.c_str(), ec.message());
}
- if (ec) {
+ if (ec || !dIter) {
if (adir->persistent()) {
removeObject(adir, containerID, false);
if (location == adir->getLocation()) {
@@ -673,7 +673,7 @@ void ContentManager::_rescanDirectory(co
adir->setCurrentLMT(location, std::chrono::seconds::zero());
std::shared_ptr<CdsObject> firstObject;
- for (auto&& dirEnt : dIter) {
+ for (auto&& dirEnt : *dIter) {
auto&& newPath = dirEnt.path();
auto&& name = newPath.filename().string();
if (name[0] == '.' && !asSetting.hidden) {

Loading…
Cancel
Save