Browse Source

Merge pull request #717 from MikePetullo/master

prosody: fix use of randomseed (prosody issue #439)
lilik-openwrt-22.03
Thomas Heil 10 years ago
parent
commit
bf6152058b
2 changed files with 13 additions and 1 deletions
  1. +1
    -1
      net/prosody/Makefile
  2. +12
    -0
      net/prosody/patches/010-fix-randomseed.patch

+ 1
- 1
net/prosody/Makefile View File

@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=prosody
PKG_VERSION:=0.9.7
PKG_RELEASE:=1
PKG_RELEASE:=2
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=http://prosody.im/downloads/source


+ 12
- 0
net/prosody/patches/010-fix-randomseed.patch View File

@ -0,0 +1,12 @@
diff -u --recursive prosody-0.9.7-vanilla/net/dns.lua prosody-0.9.7/net/dns.lua
--- prosody-0.9.7-vanilla/net/dns.lua 2015-01-02 00:26:19.981433830 -0500
+++ prosody-0.9.7/net/dns.lua 2015-01-02 00:33:10.467077715 -0500
@@ -225,7 +225,7 @@
function dns.random(...) -- - - - - - - - - - - - - - - - - - - dns.random
- math.randomseed(math.floor(10000*socket.gettime()) % 0x100000000);
+ math.randomseed(math.floor(10000*socket.gettime()) % 0x80000000);
dns.random = math.random;
return dns.random(...);
end

Loading…
Cancel
Save