Browse Source

transmission: fix build problem with fallocate64

lilik-openwrt-22.03
Cezary Jackiewicz 9 years ago
parent
commit
bf47948dc3
2 changed files with 11 additions and 9 deletions
  1. +1
    -1
      net/transmission/Makefile
  2. +10
    -8
      net/transmission/patches/010_libtransmission_fallocate64_eglibc.patch

+ 1
- 1
net/transmission/Makefile View File

@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=transmission
PKG_VERSION:=2.84
PKG_RELEASE:=1
PKG_RELEASE:=2
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
PKG_SOURCE_URL:=http://download-origin.transmissionbt.com/files/ http://mirrors.m0k.org/transmission/files


+ 10
- 8
net/transmission/patches/010_libtransmission_fallocate64_eglibc.patch View File

@ -1,12 +1,14 @@
--- a/libtransmission/fdlimit.c 2014-07-01 20:08:59.000000000 +0300
+++ b/libtransmission/fdlimit.c 2014-07-13 13:30:17.000000000 +0300
@@ -22,7 +22,8 @@
--- a/libtransmission/fdlimit.c
+++ b/libtransmission/fdlimit.c
@@ -22,11 +22,6 @@
#include <fcntl.h>
#endif
-#ifdef HAVE_FALLOCATE64
+/* no need to define fallocate64 in glibc/eglibc case */
+#if defined(__UCLIBC__) && (HAVE_FALLOCATE64)
/* FIXME can't find the right #include voodoo to pick up the declaration.. */
extern int fallocate64 (int fd, int mode, uint64_t offset, uint64_t len);
- /* FIXME can't find the right #include voodoo to pick up the declaration.. */
- extern int fallocate64 (int fd, int mode, uint64_t offset, uint64_t len);
-#endif
-
#ifdef HAVE_XFS_XFS_H
#include <xfs/xfs.h>
#endif

Loading…
Cancel
Save