Browse Source

Merge pull request #9609 from neheb/py

python: Replace utime with utimes
lilik-openwrt-22.03
Rosen Penev 5 years ago
committed by GitHub
parent
commit
bdd2b79079
No known key found for this signature in database GPG Key ID: 4AEE18F83AFDEB23
2 changed files with 12 additions and 1 deletions
  1. +1
    -1
      lang/python/python/Makefile
  2. +11
    -0
      lang/python/python/patches/025-utime.patch

+ 1
- 1
lang/python/python/Makefile View File

@ -12,7 +12,7 @@ include ../python-version.mk
PKG_NAME:=python
PKG_VERSION:=$(PYTHON_VERSION).$(PYTHON_VERSION_MICRO)
PKG_RELEASE:=8
PKG_RELEASE:=9
PKG_SOURCE:=Python-$(PKG_VERSION).tar.xz
PKG_SOURCE_URL:=https://www.python.org/ftp/python/$(PKG_VERSION)


+ 11
- 0
lang/python/python/patches/025-utime.patch View File

@ -0,0 +1,11 @@
--- a/Modules/posixmodule.c
+++ b/Modules/posixmodule.c
@@ -3070,7 +3070,7 @@ done:
if (arg == Py_None) {
/* optional time values not given */
Py_BEGIN_ALLOW_THREADS
- res = utime(path, NULL);
+ res = utimes(path, NULL);
Py_END_ALLOW_THREADS
}
else if (!PyTuple_Check(arg) || PyTuple_Size(arg) != 2) {

Loading…
Cancel
Save