Browse Source

Merge pull request #2120 from commodo/ibrcommon-fix-musl-build

ibrcommon: fix build on musl
lilik-openwrt-22.03
Hannu Nyman 9 years ago
parent
commit
bd089d3c8d
2 changed files with 24 additions and 1 deletions
  1. +1
    -1
      libs/ibrcommon/Makefile
  2. +23
    -0
      libs/ibrcommon/patches/001-fix-build-with-musl.patch

+ 1
- 1
libs/ibrcommon/Makefile View File

@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=ibrcommon
PKG_VERSION:=1.0.1
PKG_RELEASE:=1
PKG_RELEASE:=2
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=http://www.ibr.cs.tu-bs.de/projects/ibr-dtn/releases


+ 23
- 0
libs/ibrcommon/patches/001-fix-build-with-musl.patch View File

@ -0,0 +1,23 @@
diff --git a/ibrcommon/data/File.cpp b/ibrcommon/data/File.cpp
index 31af4ae..9b49890 100644
--- a/ibrcommon/data/File.cpp
+++ b/ibrcommon/data/File.cpp
@@ -35,9 +35,7 @@
#include <cerrno>
#include <fstream>
-#if !defined(HAVE_FEATURES_H) || defined(ANDROID)
#include <libgen.h>
-#endif
#ifdef __WIN32__
#include <io.h>
@@ -226,7 +224,7 @@ namespace ibrcommon
std::string File::getBasename() const
{
#if !defined(ANDROID) && defined(HAVE_FEATURES_H)
- return std::string(basename(_path.c_str()));
+ return std::string(basename((char *)_path.c_str()));
#else
char path[_path.length()+1];
::memcpy(&path, _path.c_str(), _path.length()+1);

Loading…
Cancel
Save