Browse Source

Merge pull request #8811 from neheb/ssm

ssmpt: Fix compilation without deprecated OpenSSL APIs
lilik-openwrt-22.03
Dirk Brenken 6 years ago
committed by GitHub
parent
commit
bd061e154d
No known key found for this signature in database GPG Key ID: 4AEE18F83AFDEB23
2 changed files with 14 additions and 1 deletions
  1. +1
    -1
      mail/ssmtp/Makefile
  2. +13
    -0
      mail/ssmtp/patches/020-openssl-deprecated.patch

+ 1
- 1
mail/ssmtp/Makefile View File

@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=ssmtp
PKG_VERSION:=2.64
PKG_RELEASE:=5
PKG_RELEASE:=6
PKG_MAINTAINER:=Dirk Brenken <dev@brenken.org>
PKG_LICENSE:=GPL-2.0+


+ 13
- 0
mail/ssmtp/patches/020-openssl-deprecated.patch View File

@ -0,0 +1,13 @@
--- a/ssmtp.c
+++ b/ssmtp.c
@@ -1046,8 +1046,10 @@ int smtp_open(char *host, int port)
/* Init SSL stuff */
SSL_CTX *ctx = NULL;
X509 *server_cert;
+#if OPENSSL_VERSION_NUMBER < 0x10100000L
SSL_load_error_strings();
SSLeay_add_ssl_algorithms();
+#endif
ctx = SSL_CTX_new(SSLv23_client_method());
if(!ctx) {
log_event(LOG_ERR, "No SSL support initiated\n");

Loading…
Cancel
Save