Browse Source
Merge pull request #11420 from jefferyto/python-automat-20.2.0
python-automat: Update to 20.2.0, refresh patches
lilik-openwrt-22.03
Rosen Penev
5 years ago
committed by
GitHub
No known key found for this signature in database
GPG Key ID: 4AEE18F83AFDEB23
4 changed files with
5 additions and
5 deletions
-
lang/python/python-automat/Makefile
-
lang/python/python-automat/patches/001-do-not-use-setuptools-scm-m2r.patch
-
lang/python/python-automat/patches/002-omit-visualize.patch
-
lang/python/python-automat/patches/003-omit-tests.patch
|
|
@ -8,11 +8,11 @@ |
|
|
|
include $(TOPDIR)/rules.mk |
|
|
|
|
|
|
|
PKG_NAME:=python-automat |
|
|
|
PKG_VERSION:=0.8.0 |
|
|
|
PKG_VERSION:=20.2.0 |
|
|
|
PKG_RELEASE:=1 |
|
|
|
|
|
|
|
PYPI_NAME:=Automat |
|
|
|
PKG_HASH:=269a09dfb063a3b078983f4976d83f0a0d3e6e7aaf8e27d8df1095e09dc4a484 |
|
|
|
PKG_HASH:=7979803c74610e11ef0c0d68a2942b152df52da55336e0c9d58daf1831cbdf33 |
|
|
|
|
|
|
|
PKG_LICENSE:=MIT |
|
|
|
PKG_LICENSE_FILES:=LICENSE |
|
|
|
|
|
@ -26,5 +26,5 @@ |
|
|
|
- 'm2r',
|
|
|
|
- ],
|
|
|
|
install_requires=[ |
|
|
|
"attrs>=16.1.0", |
|
|
|
"attrs>=19.2.0", |
|
|
|
"six", |
|
|
@ -1,7 +1,7 @@ |
|
|
|
--- a/setup.py
|
|
|
|
+++ b/setup.py
|
|
|
|
@@ -27,15 +27,6 @@ setup(
|
|
|
|
"attrs>=16.1.0", |
|
|
|
"attrs>=19.2.0", |
|
|
|
"six", |
|
|
|
], |
|
|
|
- extras_require={
|
|
|
|
|
|
@ -8,7 +8,7 @@ |
|
|
|
+ packages=find_packages(exclude=["*._test", "*._test.*"]),
|
|
|
|
package_dir={'automat': 'automat'}, |
|
|
|
install_requires=[ |
|
|
|
"attrs>=16.1.0", |
|
|
|
"attrs>=19.2.0", |
|
|
|
@@ -30,6 +30,7 @@ setup(
|
|
|
|
author='Glyph', |
|
|
|
author_email='glyph@twistedmatrix.com', |
|
|
|