Browse Source

netopeer2: update to 0.5.26

Signed-off-by: Matija Amidzic <matija.amidzic@sartura.hr>
lilik-openwrt-22.03
Matija Amidzic 6 years ago
parent
commit
ba647c04b5
4 changed files with 31 additions and 43 deletions
  1. +5
    -3
      net/netopeer2/Makefile
  2. +10
    -0
      net/netopeer2/files/netopeer2-server.default
  3. +16
    -0
      net/netopeer2/patches/001-fix-for-cmake-build
  4. +0
    -40
      net/netopeer2/patches/001-remove-sysrepoctl-commands-from-cmake

+ 5
- 3
net/netopeer2/Makefile View File

@ -14,11 +14,11 @@ PKG_NAME:=netopeer2
PKG_LICENSE:=BSD-3-Clause
PKG_MAINTAINER:=Mislav Novakovic <mislav.novakovic@sartura.hr>
PKG_VERSION:=0.4.13
PKG_VERSION:=0.5.26
PKG_SOURCE_PROTO:=git
PKG_SOURCE_VERSION:=ae560bef2e70d274f6d028b59e3cb398ea2a621d
PKG_MIRROR_HASH:=43b7f9c436afc76de539a7426b1462249326318b9b836f1d49282106a730a6b8
PKG_SOURCE_VERSION:=3b99e99c9d507ddc89d21d7f1cbded494e6aa72e
PKG_MIRROR_HASH:=d29b501d56bf9a2480759cc55368c842f69b07722afb3a0a70f05d6088f72574
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)-$(PKG_SOURCE_VERSION).tar.xz
PKG_SOURCE_URL:=https://github.com/CESNET/Netopeer2.git
PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)-$(PKG_SOURCE_VERSION)
@ -86,6 +86,8 @@ define Package/netopeer2-server/install
$(INSTALL_DATA) $(PKG_BUILD_ROOT)/modules/iana-crypt-hash.yang $(1)/etc/sysrepo/yang/iana-crypt-hash@2014-08-06.yang
$(INSTALL_DATA) $(PKG_BUILD_ROOT)/modules/ietf-x509-cert-to-name.yang $(1)/etc/sysrepo/yang/ietf-x509-cert-to-name@2014-12-10.yang
$(INSTALL_DATA) $(PKG_BUILD_ROOT)/modules/ietf-netconf-server.yang $(1)/etc/sysrepo/yang/ietf-netconf-server@2016-11-02.yang
$(INSTALL_DATA) $(PKG_BUILD_ROOT)/modules/ietf-netconf-monitoring.yang $(1)/etc/sysrepo/yang/ietf-netconf-monitoring@2010-10-04.yang
$(INSTALL_DATA) $(PKG_BUILD_ROOT)/modules/ietf-netconf-with-defaults.yang $(1)/etc/sysrepo/yang/ietf-netconf-with-defaults@2011-06-01.yang
$(INSTALL_DATA) $(PKG_BUILD_ROOT)/modules/ietf-system.yang $(1)/etc/sysrepo/yang/ietf-system@2014-08-06.yang
$(INSTALL_DIR) $(1)/etc/uci-defaults


+ 10
- 0
net/netopeer2/files/netopeer2-server.default View File

@ -34,6 +34,16 @@ if [ -x /bin/sysrepoctl ]; then
fi
fi
match=$(sysrepoctl -l | grep "ietf-netconf-monitoring ")
if [ ! "$match" ]; then
sysrepoctl --install --yang=/etc/sysrepo/yang/ietf-netconf-monitoring@2010-10-04.yang -o root:root -p 600
fi
match=$(sysrepoctl -l | grep "ietf-netconf-with-defaults ")
if [ ! "$match" ]; then
sysrepoctl --install --yang=/etc/sysrepo/yang/ietf-netconf-with-defaults@2011-06-01.yang -o root:root -p 600
fi
match=$(sysrepoctl -l | grep "ietf-system ")
if [ ! "$match" ]; then
sysrepoctl --install --yang=/etc/sysrepo/yang/ietf-system@2014-08-06.yang -o root:root -p 600


net/netopeer2/patches/002-fix-for-cmake-build → net/netopeer2/patches/001-fix-for-cmake-build View File


+ 0
- 40
net/netopeer2/patches/001-remove-sysrepoctl-commands-from-cmake View File

@ -1,40 +0,0 @@
Index: netopeer2-c204b59f9c2bb7e63eb907f33c44adbf208295ee/keystored/CMakeLists.txt
===================================================================
--- netopeer2-c204b59f9c2bb7e63eb907f33c44adbf208295ee.orig/keystored/CMakeLists.txt
+++ netopeer2-c204b59f9c2bb7e63eb907f33c44adbf208295ee/keystored/CMakeLists.txt
@@ -105,6 +105,7 @@ endif()
install(DIRECTORY DESTINATION ${KEYSTORED_KEYS_DIR}
DIRECTORY_PERMISSIONS OWNER_WRITE OWNER_READ OWNER_EXECUTE)
+if(FALSE)
# install all the required modules and enable features
install(CODE "
execute_process(COMMAND ${SYSREPOCTL_EXECUTABLE} -l RESULT_VARIABLE RET OUTPUT_VARIABLE INSTALLED_MODULES ERROR_VARIABLE OUT)
@@ -154,6 +155,7 @@ install(CODE "
message(FATAL_ERROR \" Command sysrepocfg import failed:\\n \${OUT}\")
endif()
endif()")
+endif()
# plugins should be installed into sysrepo plugins dir
install(TARGETS keystored DESTINATION ${SR_PLUGINS_DIR})
Index: netopeer2-c204b59f9c2bb7e63eb907f33c44adbf208295ee/server/CMakeLists.txt
===================================================================
--- netopeer2-c204b59f9c2bb7e63eb907f33c44adbf208295ee.orig/server/CMakeLists.txt
+++ netopeer2-c204b59f9c2bb7e63eb907f33c44adbf208295ee/server/CMakeLists.txt
@@ -147,6 +147,7 @@ include_directories(${SYSREPO_INCLUDE_DI
# install binary
install(TARGETS netopeer2-server DESTINATION ${CMAKE_INSTALL_BINDIR})
+if(FALSE)
# only for configuration
if (ENABLE_CONFIGURATION)
# find sysrepoctl
@@ -239,6 +240,7 @@ if (ENABLE_CONFIGURATION)
endif()")
endif()
+endif()
# clean cmake cache
add_custom_target(cleancache

Loading…
Cancel
Save