Browse Source
softethervpn: Add missing OpenSSL header
Fixes compilation without OpenSSL deprecated APIs as well as
-Werror=implicit-function-declaration.
Signed-off-by: Rosen Penev <rosenp@gmail.com>
lilik-openwrt-22.03
Rosen Penev
5 years ago
No known key found for this signature in database
GPG Key ID: 36D31CFA845F0E3B
2 changed files with
11 additions and
1 deletions
-
net/softethervpn/Makefile
-
net/softethervpn/patches/140-openssl-header.patch
|
|
@ -12,7 +12,7 @@ PKG_NAME:=softethervpn |
|
|
|
PKG_VERSION:=4.29-9680 |
|
|
|
PKG_VERREL:=rtm |
|
|
|
PKG_VERDATE:=2019.02.28 |
|
|
|
PKG_RELEASE:=1 |
|
|
|
PKG_RELEASE:=2 |
|
|
|
|
|
|
|
PKG_SOURCE:=softether-src-v$(PKG_VERSION)-$(PKG_VERREL).tar.gz |
|
|
|
PKG_SOURCE_URL:=http://www.softether-download.com/files/softether/v$(PKG_VERSION)-$(PKG_VERREL)-$(PKG_VERDATE)-tree/Source_Code/ |
|
|
|
|
|
@ -0,0 +1,10 @@ |
|
|
|
--- a/src/Mayaqua/Secure.c
|
|
|
|
+++ b/src/Mayaqua/Secure.c
|
|
|
|
@@ -127,6 +127,7 @@
|
|
|
|
#include <openssl/pkcs7.h> |
|
|
|
#include <openssl/pkcs12.h> |
|
|
|
#include <openssl/rc4.h> |
|
|
|
+#include <openssl/rsa.h>
|
|
|
|
#include <openssl/md5.h> |
|
|
|
#include <openssl/sha.h> |
|
|
|
#include <Mayaqua/Mayaqua.h> |