Browse Source

gnunet: update source

Most of the local patches have been integrated upstream.

Signed-off-by: Daniel Golle <daniel@makrotopia.org>
lilik-openwrt-22.03
Daniel Golle 9 years ago
parent
commit
b6e1de2bdc
5 changed files with 2 additions and 120 deletions
  1. +1
    -1
      net/gnunet/Makefile
  2. +1
    -1
      net/gnunet/patches/010-cross-compile-fixes.patch
  3. +0
    -30
      net/gnunet/patches/011-no-fpu-includes.patch
  4. +0
    -77
      net/gnunet/patches/100-musl-malloc.patch
  5. +0
    -11
      net/gnunet/patches/101-include-byteswap.patch

+ 1
- 1
net/gnunet/Makefile View File

@ -8,7 +8,7 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=gnunet
PKG_SOURCE_VERSION:=35933
PKG_SOURCE_VERSION:=35937
PKG_VERSION:=0.10.1-svn$(PKG_SOURCE_VERSION)
PKG_RELEASE:=1


+ 1
- 1
net/gnunet/patches/010-cross-compile-fixes.patch View File

@ -1,6 +1,6 @@
--- a/configure.ac
+++ b/configure.ac
@@ -194,7 +194,7 @@ AM_CONDITIONAL(GNU, test "$build_target"
@@ -189,7 +189,7 @@ AM_CONDITIONAL(GNU, test "$build_target"
AC_MSG_RESULT([$build_target])
AC_SUBST(build_target)
AM_CONDITIONAL([am__fastdepOBJC], false)


+ 0
- 30
net/gnunet/patches/011-no-fpu-includes.patch View File

@ -1,30 +0,0 @@
--- a/src/dht/gnunet-service-dht_neighbours.c
+++ b/src/dht/gnunet-service-dht_neighbours.c
@@ -45,7 +45,6 @@
#include "gnunet-service-dht_neighbours.h"
#include "gnunet-service-dht_nse.h"
#include "gnunet-service-dht_routing.h"
-#include <fenv.h>
#include "dht.h"
#define LOG_TRAFFIC(kind,...) GNUNET_log_from (kind, "dht-traffic",__VA_ARGS__)
--- a/src/dht/gnunet-service-wdht_neighbours.c
+++ b/src/dht/gnunet-service-wdht_neighbours.c
@@ -44,7 +44,6 @@
#include "gnunet-service-wdht_datacache.h"
#include "gnunet-service-wdht_neighbours.h"
#include "gnunet-service-wdht_nse.h"
-#include <fenv.h>
#include <stdlib.h>
#include <string.h>
#include "dht.h"
--- a/src/dht/gnunet-service-xdht_neighbours.c
+++ b/src/dht/gnunet-service-xdht_neighbours.c
@@ -41,7 +41,6 @@
#include "gnunet-service-xdht_datacache.h"
#include "gnunet-service-xdht_neighbours.h"
#include "gnunet-service-xdht_routing.h"
-#include <fenv.h>
#include "dht.h"
/**

+ 0
- 77
net/gnunet/patches/100-musl-malloc.patch View File

@ -1,77 +0,0 @@
--- a/src/util/gnunet-service-resolver.c
+++ b/src/util/gnunet-service-resolver.c
@@ -603,7 +603,7 @@ main (int argc, char *const *argv)
return ret;
}
-#ifdef LINUX
+#if defined(LINUX) && defined(__GLIBC__)
#include <malloc.h>
/**
--- a/src/arm/gnunet-service-arm.c
+++ b/src/arm/gnunet-service-arm.c
@@ -1563,7 +1563,7 @@ main (int argc, char *const *argv)
}
-#ifdef LINUX
+#if defined(LINUX) && defined(__GLIBC__)
#include <malloc.h>
/**
--- a/src/nse/gnunet-service-nse.c
+++ b/src/nse/gnunet-service-nse.c
@@ -1629,7 +1629,7 @@ main (int argc,
}
-#ifdef LINUX
+#if defined(LINUX) && defined(__GLIBC__)
#include <malloc.h>
/**
--- a/src/regex/gnunet-daemon-regexprofiler.c
+++ b/src/regex/gnunet-daemon-regexprofiler.c
@@ -382,7 +382,7 @@ main (int argc, char *const *argv)
}
-#ifdef LINUX
+#if defined(LINUX) && defined(__GLIBC__)
#include <malloc.h>
/**
--- a/src/revocation/gnunet-service-revocation.c
+++ b/src/revocation/gnunet-service-revocation.c
@@ -933,7 +933,7 @@ main (int argc,
}
-#ifdef LINUX
+#if defined(LINUX) && defined(__GLIBC__)
#include <malloc.h>
--- a/src/statistics/gnunet-service-statistics.c
+++ b/src/statistics/gnunet-service-statistics.c
@@ -1077,7 +1077,7 @@ main (int argc, char *const *argv)
&run, NULL)) ? 0 : 1;
}
-#ifdef LINUX
+#if defined(LINUX) && defined(__GLIBC__)
#include <malloc.h>
/**
--- a/src/topology/gnunet-daemon-topology.c
+++ b/src/topology/gnunet-daemon-topology.c
@@ -1327,7 +1327,7 @@ main (int argc, char *const *argv)
}
-#ifdef LINUX
+#if defined(LINUX) && defined(__GLIBC__)
#include <malloc.h>
/**

+ 0
- 11
net/gnunet/patches/101-include-byteswap.patch View File

@ -1,11 +0,0 @@
--- a/src/include/gnunet_common.h
+++ b/src/include/gnunet_common.h
@@ -49,6 +49,8 @@
#include <stdarg.h>
#endif
+#include <byteswap.h>
+
#ifdef __cplusplus
extern "C"
{

Loading…
Cancel
Save