Browse Source

nbd: Update to 3.19 and remove unneed patches

Current version in OpenWrt (3.16.2) fails against the Arch Linux
in System Rescue CD's NBD as rootfs (to allow sharing ISO across
network).  Based on resolved issues and web searching it seems
nbd had endianness issues (which affected my ath79 device).

This updates to 3.19 which allows System Rescue CD PXE boot with
NBD rootfs to work.

Removed patches no longer required due to upstream changes, and
added new configure option (--without-libnl) required to avoid
linking against full libnl and libnl-genl (if present in build).

Signed-off-by: Daniel F. Dickinson <cshored@thecshore.com>
lilik-openwrt-22.03
Daniel F. Dickinson 5 years ago
parent
commit
b6da58fabf
3 changed files with 5 additions and 29 deletions
  1. +5
    -3
      net/nbd/Makefile
  2. +0
    -15
      net/nbd/patches/100-make-gnutls-test-optional.patch
  3. +0
    -11
      net/nbd/patches/101-fix-build-without-gnutls.patch

+ 5
- 3
net/nbd/Makefile View File

@ -8,12 +8,12 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=nbd
PKG_VERSION:=3.16.2
PKG_VERSION:=3.19
PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
PKG_SOURCE_URL:=@SF/nbd
PKG_HASH:=422f62bdf6e6b973bd82083dc52b6577396fe00aa6607837ac464e476124155b
PKG_HASH:=b4466412f13e057659f25d35e1e8e181afd62c7179bff22a6add81445ecb8690
PKG_LICENSE:=GPL-2.0+
PKG_MAINTAINER:=Marcin Jurkowski <marcin1j@gmail.com>
@ -52,7 +52,9 @@ endef
CONFIGURE_ARGS += \
--disable-glibtest \
--without-gnutls
--without-gnutls \
--without-libnl \
--with-syslog
TARGET_CFLAGS += --std=gnu99 -DNODAEMON


+ 0
- 15
net/nbd/patches/100-make-gnutls-test-optional.patch View File

@ -1,15 +0,0 @@
--- a/configure.ac
+++ b/configure.ac
@@ -210,7 +210,11 @@ dnl ;;
dnl esac
dnl fi
-PKG_CHECK_MODULES(GnuTLS, [gnutls >= 2.12.0],[HAVE_GNUTLS=1],[HAVE_GNUTLS=0])
+AC_ARG_WITH([gnutls], AS_HELP_STRING([--with-gnutls], [Build with GnuTLS]))
+AS_IF([test "x$with_gnutls" = "xyes"], [
+ PKG_CHECK_MODULES(GnuTLS, [gnutls >= 2.12.0],[HAVE_GNUTLS=1],[HAVE_GNUTLS=0])
+])
+
if test x$HAVE_GNUTLS = x1; then
AC_DEFINE(HAVE_GNUTLS, 1, [Define to 1 if you have a GnuTLS version of 2.12 or above])
else

+ 0
- 11
net/nbd/patches/101-fix-build-without-gnutls.patch View File

@ -1,11 +0,0 @@
--- a/Makefile.am
+++ b/Makefile.am
@@ -35,7 +35,7 @@ nbd_client_CFLAGS = $(client_flags) @Gnu
nbd_client_LDADD = $(client_libs) @GnuTLS_LIBS@
else
nbd_client_SOURCES = $(client_srcs)
-nbd_client_CFLAGS = $(client_flags)
+nbd_client_CFLAGS = $(client_flags) -DNOTLS -DPROG_NAME='"nbd-client"'
nbd_client_LDADD = $(client_libs)
endif
endif

Loading…
Cancel
Save