Browse Source

openldap: Add static function declaration

Fixes compilation with -Werror=implicit-function-declaration .

Signed-off-by: Rosen Penev <rosenp@gmail.com>
lilik-openwrt-22.03
Rosen Penev 5 years ago
parent
commit
b52e226c3b
No known key found for this signature in database GPG Key ID: 36D31CFA845F0E3B
2 changed files with 11 additions and 1 deletions
  1. +1
    -1
      libs/openldap/Makefile
  2. +10
    -0
      libs/openldap/patches/800-implicit.patch

+ 1
- 1
libs/openldap/Makefile View File

@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=openldap
PKG_VERSION:=2.4.47
PKG_RELEASE:=2
PKG_RELEASE:=3
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tgz
PKG_SOURCE_URL:=https://gpl.savoirfairelinux.net/pub/mirrors/openldap/openldap-release/ \


+ 10
- 0
libs/openldap/patches/800-implicit.patch View File

@ -0,0 +1,10 @@
--- a/libraries/libldap/tls2.c
+++ b/libraries/libldap/tls2.c
@@ -41,6 +41,7 @@ static tls_impl *tls_imp = &ldap_int_tls_impl;
#define HAS_TLS( sb ) ber_sockbuf_ctrl( sb, LBER_SB_OPT_HAS_IO, \
(void *)tls_imp->ti_sbio )
+static int ldap_pvt_tls_check_hostname( LDAP *ld, void *s, const char *name_in );
#endif /* HAVE_TLS */
#ifdef LDAP_DEVEL

Loading…
Cancel
Save