Browse Source

Merge pull request #11110 from srchack/open-vm-tools-bump-11.0.5

open-vm-tools: bump to version 11.0.5
lilik-openwrt-22.03
Rosen Penev 5 years ago
committed by GitHub
parent
commit
b494b7a0d8
No known key found for this signature in database GPG Key ID: 4AEE18F83AFDEB23
3 changed files with 52 additions and 6 deletions
  1. +4
    -4
      utils/open-vm-tools/Makefile
  2. +2
    -2
      utils/open-vm-tools/patches/0005-Use-configure-to-test-for-feature-instead-of-platfor.patch
  3. +46
    -0
      utils/open-vm-tools/patches/0014-resolve-musl-does-not-implement-res_ninit.patch

+ 4
- 4
utils/open-vm-tools/Makefile View File

@ -8,13 +8,13 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=open-vm-tools
PKG_VERSION:=11.0.1
PKG_VERSION:=11.0.5
PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)-14773994.tar.gz
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)-15389592.tar.gz
PKG_SOURCE_URL:=https://github.com/vmware/open-vm-tools/releases/download/stable-$(PKG_VERSION)
PKG_HASH:=8a707df98b6eb40195d7deaf09def5ef03c19c83ca418f8bf23c18405ebf2981
PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)-14773994
PKG_HASH:=fc5ed2d752af33775250e0f103d622c0031d578f8394511617d2619b124dfc42
PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)-15389592
PKG_INSTALL:=1
PKG_BUILD_DEPENDS:=glib2/host


+ 2
- 2
utils/open-vm-tools/patches/0005-Use-configure-to-test-for-feature-instead-of-platfor.patch View File

@ -88,10 +88,10 @@ diff -urN a/lib/misc/idLinux.c b/lib/misc/idLinux.c
diff -urN a/lib/nicInfo/nicInfoPosix.c b/lib/nicInfo/nicInfoPosix.c
--- a/lib/nicInfo/nicInfoPosix.c
+++ b/lib/nicInfo/nicInfoPosix.c
@@ -34,9 +34,13 @@
#include <sys/socket.h>
@@ -35,9 +35,13 @@
#include <sys/stat.h>
#include <errno.h>
#include <limits.h>
-#if defined(__FreeBSD__) || defined(__APPLE__)
+#if HAVE_SYS_SYSCTL_H
# include <sys/sysctl.h>


+ 46
- 0
utils/open-vm-tools/patches/0014-resolve-musl-does-not-implement-res_ninit.patch View File

@ -0,0 +1,46 @@
diff -urNp a/lib/nicInfo/nicInfoPosix.c b/lib/nicInfo/nicInfoPosix.c
--- a/lib/nicInfo/nicInfoPosix.c
+++ b/lib/nicInfo/nicInfoPosix.c
@@ -65,6 +65,9 @@
#include <netinet/in.h>
#include <arpa/nameser.h>
#include <resolv.h>
+#if defined(__linux__) && !defined(__GLIBC__)
+#include "resolv_compat.h"
+#endif
#ifdef __linux__
# include <net/if.h>
diff -urNp a/lib/nicInfo/resolv_compat.h b/lib/nicInfo/resolv_compat.h
--- a/lib/nicInfo/resolv_compat.h
+++ b/lib/nicInfo/resolv_compat.h
@@ -0,0 +1,29 @@
+#if !defined(__GLIBC__)
+/***************************************************************************
+ * resolv_compat.h
+ *
+ * Mimick GLIBC's res_ninit() and res_nclose() for musl libc
+ * Note: res_init() is actually deprecated according to
+ * http://docs.oracle.com/cd/E36784_01/html/E36875/res-nclose-3resolv.html
+ **************************************************************************/
+#include <string.h>
+
+static inline int res_ninit(res_state statp)
+{
+ int rc = res_init();
+ if (statp != &_res) {
+ memcpy(statp, &_res, sizeof(*statp));
+ }
+ return rc;
+}
+
+static inline int res_nclose(res_state statp)
+{
+ if (!statp)
+ return -1;
+ if (statp != &_res) {
+ memset(statp, 0, sizeof(*statp));
+ }
+ return 0;
+}
+#endif

Loading…
Cancel
Save